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INTRODUCTION 

This manual describes the setting procedure for connecting the FX5 CPU module and the KV series module 
manufactured by KEYENCE CORPORATION using the simple CPU communication function and the operation 
check method. 
This manual describes the connection procedure until the connection is established. This manual does not 
describe the operation other than the connection procedure, installation, and device functions and specifications. 
Please read this manual and the relevant manuals or consult the product manufacturer and fully understand the 
specifications before attempting to use the product. 

Safety guidelines 

 Before using this product described in this manual, read this manual. 
 This product has been manufactured as a general-purpose part for general industries, and has not been 

designed or manufactured to be incorporated in a device or system used in purposes related to human life. 
 Before using the product for special purposes such as nuclear power, electric power, aerospace, medicine, or 

passenger movement vehicles, consult Mitsubishi Electric. 
 This product has been manufactured under strict quality control. However when installing the product where 

major accidents or losses could occur if the product fails, install appropriate backup or failsafe functions in the 
system. 

 For design precautions and wiring precautions, read safety precautions described in the relevant manuals. 

Note 

 If in doubt at any stage during the installation of the product, always consult a professional electrical engineer 
who is qualified and trained in the local and national standards. If in doubt about the operation or use, please 
consult the nearest Mitsubishi Electric representative. 

 Since the examples indicated by this manual, technical bulletin, catalog, etc. are used as a reference and do 
not guarantee operation, please use the product after confirming for yourself the function and safety of the 
device and machine. 

 The content, including specifications, in this manual may be changed for improvement without notice. 
 For devices other than those manufactured by Mitsubishi Electric described in this manual, please acquire 

manuals and check the safety precautions and descriptions. 
 The information in this manual has been carefully checked and is believed to be accurate; however, if you 

have noticed a doubtful point or a doubtful error, please contact your local Mitsubishi Electric representative. 
When doing so, please provide the manual number given at the end of this manual. 

  



 

 
2 

 

CONTENTS 

INTRODUCTION .......................................................................................................................................................1 
CONTENTS ...............................................................................................................................................................2 
RELEVANT MANUALS .............................................................................................................................................3 
1. OVERVIEW ........................................................................................................................................................4 

1.1 Applicable Devices ......................................................................................................................................4 
1.2 System Configuration ..................................................................................................................................5 

2. SETTINGS FOR THE KV-8000 .........................................................................................................................6 
2.1 Parameter Setting .......................................................................................................................................6 

3. SETTINGS FOR THE FX5U ..............................................................................................................................8 
3.1 Parameter Setting .......................................................................................................................................8 

4. OPERATION CHECK ......................................................................................................................................10 
4.1 Operation Example ...................................................................................................................................10 
4.2 Check method ...........................................................................................................................................10 

REVISIONS .............................................................................................................................................................12 
WARRANTY ............................................................................................................................................................12 
TRADEMARKS ........................................................................................................................................................12 
  



 

 
3 

 

RELEVANT MANUALS 

The following lists the relevant manuals. Please download those manuals from the website of each 
manufacturer. 

◼ Mitsubishi Electric 

Manual name Manual number 

MELSEC iQ-F FX5S/FX5UJ/FX5U/FX5UC User's Manual (Hardware) SH-082452ENG 

MELSEC iQ-F FX5 User's Manual (Application) JY997D55401 

MELSEC iQ-F FX5 User's Manual (Ethernet Communication) JY997D56201 

GX Works3 Operating Manual SH-081215ENG 

◼ KEYENCE CORPORATION 

Manual name Manual number 

KV-8000 Series User's Manual - 

KV STUDIO Ver.11 User's Manual - 

KV-EP21V/8000 (A)/7500/5500/NC1EP User's Manual - 
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1. OVERVIEW 

An FX5 CPU module is connected with a KV series module manufactured by KEYENCE CORPORATION using 
the simple CPU communication function. 
The simple CPU communication function communicates the specified device data at a specified timing just by 
setting simple parameters from GX Works3. Assign an IP address to the FX5 CPU module and KV series 
module and set the communication destination and device in the simple CPU communication setting of GX 
Works3. 

 

1.1 Applicable Devices 

The following table lists the devices that support the simple CPU communication function described in this 
manual. 

Manufacturer Applicable device 

Mitsubishi Electric 

FX5U CPU module 

FX5UC CPU module 

FX5UJ CPU module 

FX5S CPU module 

KEYENCE CORPORATION KV series 
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1.2 System Configuration 

In this manual, the following system configuration is used as an example. 

 

Manufacturer Device/Software Model 

(1) KEYENCE CORPORATION KV series KV-8000 

(2) - 
Configuration personal 
computer (OS: Windows 10) 

- 

(3) - Switching hub - 

(4) Mitsubishi Electric FX5 CPU module 

FX5U-32MT/ES 

Serial number: 17X**** or later 

Firmware version: 1.210 or later 

- Mitsubishi Electric Engineering software 

GX Works3 

Version: 1.065T or later 

(In this manual, Ver.1.085P is used as an 
example.) 

- KEYENCE CORPORATION 
Programming support 
software 

KV STUDIO 

 

❖ Point 

 Set the IP addresses of devices so that they are all on the same network. 

 Available functions and settings differ depending on the device used or software version, thus the product 
with the version described in this chapter must be used. The setting procedure or setting windows may 
differ from those in this manual depending on the product version used. In such a case, refer to the relevant 
manuals of each manufacturer and software help. 

  

(2)
(1) (4)

(3)

IP address: 192.168.3.1

IP address:
192.168.3.100

IIP address: 192.168.3.250
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2. SETTINGS FOR THE KV-8000 

Set the parameters of the KV-8000 using KV STUDIO (programming support software) manufactured by 
KEYENCE CORPORATION. 

2.1 Parameter Setting 

❖ Point 

 Check that the RUN-PRG Selector Switch of the PLC is in the RUN state. 

 No ladder program for communications is required. 
 

 

1. From the KV STUDIO menu, select [File] → [New 
project]. Set the applicable model, any project 
name, and project save location, and click the 
[OK] button. 

 

2. From the KV STUDIO menu, select [Tool] → 
[Unit Editor]. 

3. Drag and drop the power unit to the unit editor 
window in accordance with the system 
configuration, and double-click the KV-8000. 
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4. In the [Setup unit(2)] tab, set the IP address and 
subnet mask of the KV-8000. 
 
IP Address: 192.168.3.1 
Subnet Mask: 255.255.255.0 (default) 

5. Click [Apply] to save the settings. 

 6. Connect the configuration personal computer 
with the PLC. From the KV STUDIO menu, select 
[Monitor/Simulator] → [PLC transfer → monitor 
mode]. Select the transfer item and click the 
[Execute] button. 
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3. SETTINGS FOR THE FX5U 

Set the parameters of the MELSEC iQ-F series FX5U CPU module using GX Works3. 

3.1 Parameter Setting 

 

 

1. From the GX Works3 menu, select [Project] → 
[New]. Set the series and model, and click the 
[OK] button. 

 

2. In [Navigation], select [Parameter] → [FX5UCPU] 
→ [Module Parameter] → [Ethernet Port] → [Basic 
Settings]. 

3. Set the IP address and subnet mask of the FX5U 
CPU module.  
 
IP Address: 192.168.3.250 
Subnet Mask: 255.255.255.0 

 

4. Select [Application Settings]. 

5. Set "Use" for "To Use or Not to Use Simple 
Communication". 

6. Double-click "<Detailed Setting>" of "Simple CPU 
Communication Setting". 
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<Setting No.1> 

 

7. Select the communication pattern of Setting No.1.  
 
Communication Pattern: Read 

8. Click the [...] button of "Source" of 
"Communication Destination". 
 

9. Set each item on the "Communication Destination 
Setting" window as follows.  
 
Device Type: KEYENCE(KV series) 
IP Address: 192.168.3.1 
Host Station Port No.: 5570 

10. Click the [OK] button. 

 

 
 
 
 
 
 
 

11. Set the devices that are sent/received to/from the 
communication destination as follows. 

Bit Device Word Device 

Source Destination Source Destination 

Type Start End Type Start End Type Start End Type Start End 

R 100 115 X 200 217 W 00100 00100 D 200 200 
 

 

12. Set the communication pattern and 
communication destination for Setting No.2 as 
follows in the same way of Setting No.1.  
 
Communication Pattern: Write 
Device Type: KEYENCE(KV series) 
IP Address: 192.168.3.1 
Host Station Port No.: 5571 

 

13. Set the devices for Setting No.2 as follows. 

Bit Device Word Device 

Source Destination Source Destination 

Type Start End Type Start End Type Start End Type Start End 

X 100 117 R 0 15 D 100 100 W 00000 00000 

14. Click the [Apply] button after setting. 

 
15. The set parameters are written to the CPU 

module. Then reset or power off and on the CPU 
module. 
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4. OPERATION CHECK 

Check whether the FX5U-32MT/ES and KV-8000 communicate successfully in the simple CPU communication. 
If an error occurs, refer to the following manuals. 
 Troubleshooting in the MELSEC iQ-F FX5 User's Manual (Ethernet Communication) 
 List of PLC Unit Errors in the KV-8000 Series User's Manual 

4.1 Operation Example 

The specified bit device value or word device value is periodically communicated between the FX5U-32MT/ES 
and the KV-8000. Check that the data is read/written correctly using the watch window of GX Works3 and the 
registration monitor window of KV STUDIO. 

 

4.2 Check method 

Check whether the device data is read/written by using the watch window of GX Works3 and the registration 
monitor window of the KV STUDIO. 
 

 

1. Start GX Works3. Select [View] → [Docking 
Window] → [Watch 1] to display the "Watch" 
widow. 

2. Register D100, X117, D200, and X200 on the 
"Watch" window. 

3. Select [Online] → [Watch] → [Start Watching]. 

 

4. Start KV STUDIO. Select [Monitor/Simulator] → 
[Monitor mode] to set the monitor mode. 

5. Select [Monitor/Simulator] → [Register monitor 
window] to display the "Registration monitor" 
window. Set W00, R015, W0100, and R100. 

 

❖ Point 

Set a device within the range of devices set in the simple CPU communication setting of GX Works3 on the 
window. 
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<GX Works3> 

 

<KV STUDIO> 

 

6. Check that the device data is written from the 
FX5U-32MT/ES to the KV-8000.  
In this manual, enter 5 to the current value of 
D100 and 1 to the current value of X117 in GX 
Works3. 

7. When W00 is 5 and R015 is  in KV STUDIO, 
the device data is written successfully. 

8. Check that the device data is read from the KV-
8000 to the FX5U-32MT/ES.  
In this manual, enter 3 to the current value of 
W0100 and double-click the current value of 
R100 and change it to  in KV STUDIO. 

9. When D200 is 3 and X200 is 1 in GX Works3, 
the device data is read successfully. 
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REVISIONS 

Revision date Revision Description 

January 2023 A First edition 

 
 

WARRANTY 

Please confirm the following product warranty details before using this product. 
 MELSEC iQ-F FX5S/FX5UJ/FX5U/FX5UC User's Manual (Hardware) [WARRANTY] 
 Manual for KV series manufactured by KEYENCE CORPORATION used [WARRANTIES AND 

DISCLAIMERS] 
 
 

TRADEMARKS 

The company names, system names and product names mentioned in this manual are either registered 
trademarks or trademarks of their respective companies. 
In some cases, trademark symbols are not specified in this manual. 
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