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IntroductionIntroduction Purpose of the CoursePurpose of the Course

This course is designed for anyone new to the Simple Motion mode of the MELSEC iQ-R/iQ-F Series Motion modules to learnThis course is designed for anyone new to the Simple Motion mode of the MELSEC iQ-R/iQ-F Series Motion modules to learn
about system design, installation, wiring, setting, and programming.about system design, installation, wiring, setting, and programming.

This course requires the basic knowledge of the MELSEC iQ-R Series programmable controller or MELSEC iQ-F SeriesThis course requires the basic knowledge of the MELSEC iQ-R Series programmable controller or MELSEC iQ-F Series
programmable controller in addition to AC servos and positioning control.programmable controller in addition to AC servos and positioning control.

For beginners, we recommend the following courses.For beginners, we recommend the following courses.

"MELSEC iQ-R Series Basic" Course or "MELSEC iQ-F Series Basics" Course"MELSEC iQ-R Series Basic" Course or "MELSEC iQ-F Series Basics" Course

"GX Works3 (Ladder)" Course"GX Works3 (Ladder)" Course

"MELSERVO Basics (MR-J5)" Course"MELSERVO Basics (MR-J5)" Course

"FA Equipment for Beginners (Positioning)" Course"FA Equipment for Beginners (Positioning)" Course

PLCopenPLCopen®® is the registered trademark of PLCopen. is the registered trademark of PLCopen.



IntroductionIntroduction Course StructureCourse Structure

The contents of this course are as follows.The contents of this course are as follows.
We recommend that you start from Chapter 1.We recommend that you start from Chapter 1.

Chapter 1 Overview of Simple Motion ModeChapter 1 Overview of Simple Motion Mode

This chapter describes the overview of Simple Motion mode and differences from the PLCopenThis chapter describes the overview of Simple Motion mode and differences from the PLCopen®® motion control FB mode. motion control FB mode.

Chapter 2 System of Simple Motion ModeChapter 2 System of Simple Motion Mode

This chapter describes the hardware configuration of the servo system used in this course.This chapter describes the hardware configuration of the servo system used in this course.

Chapter 3 Creating a ProjectChapter 3 Creating a Project

This chapter describes the procedure that begins with creating a project and extends through the setting of each parameter.This chapter describes the procedure that begins with creating a project and extends through the setting of each parameter.

Chapter 4 Positioning Control and Interpolation Control ProgramChapter 4 Positioning Control and Interpolation Control Program

This chapter describes the initial setting (all axis servo ON), JOG operation, and program for operating the positioning data.This chapter describes the initial setting (all axis servo ON), JOG operation, and program for operating the positioning data.

Chapter 5 Digital OscilloscopeChapter 5 Digital Oscilloscope

This chapter describes how to check the operation of the sample program by using a digital oscilloscope.This chapter describes how to check the operation of the sample program by using a digital oscilloscope.

Final TestFinal Test

5 sections in total (19 questions) Passing grade: 60% or higher5 sections in total (19 questions) Passing grade: 60% or higher



IntroductionIntroduction How to Use This e-Learning ToolHow to Use This e-Learning Tool

Go to the next pageGo to the next page Go to the next page.Go to the next page.

Back to the previous pageBack to the previous page Back to the previous page.Back to the previous page.

Move to the desired pageMove to the desired page "Table of Contents" will be displayed, enabling you to navigate to the desired page."Table of Contents" will be displayed, enabling you to navigate to the desired page.

Exit the learningExit the learning Exit the learning. Window such as "Contents" screen and the learning will be closed.Exit the learning. Window such as "Contents" screen and the learning will be closed.



IntroductionIntroduction Precautions for UsePrecautions for Use

■Safety precautions■Safety precautions

When you learn based on using actual products, please carefully read the safety precautions in the corresponding manualsWhen you learn based on using actual products, please carefully read the safety precautions in the corresponding manuals
and handle the product properly while taking all precautions for safety.and handle the product properly while taking all precautions for safety.

■Precautions in this course■Precautions in this course

The screen images shown in the course may differ from your actual software depending on the version.The screen images shown in the course may differ from your actual software depending on the version.
The following software versions are used in the course.The following software versions are used in the course.
For the latest version of each software, check the Mitsubishi Electric FA Website.For the latest version of each software, check the Mitsubishi Electric FA Website.

   MELSOFT GX Works3MELSOFT GX Works3 Ver.1.082LVer.1.082L Simple Motion Module SettingSimple Motion Module Setting Ver.1.172EVer.1.172E
   MELSOFT MR Configurator2MELSOFT MR Configurator2 Ver.1.130LVer.1.130L

The content of this course involves restrictions on the firmware version of each module.The content of this course involves restrictions on the firmware version of each module.

The firmware version of the iQ-R PLC CPU must be 44 or later (12 or later for R00/01/02CPU).The firmware version of the iQ-R PLC CPU must be 44 or later (12 or later for R00/01/02CPU).

The firmware version of the RD78G Motion module must be 16 or later.The firmware version of the RD78G Motion module must be 16 or later.

The firmware version of the iQ-F PLC CPU must be 1.230 or later.The firmware version of the iQ-F PLC CPU must be 1.230 or later.

The firmware version of the FX5-□SSC-G Motion module must be 1.001 or later.The firmware version of the FX5-□SSC-G Motion module must be 1.001 or later.

For how to update the firmware version, refer to the Mitsubishi Electric FA Website or the module configuration manual.For how to update the firmware version, refer to the Mitsubishi Electric FA Website or the module configuration manual.

The book The book  icon indicates the reference manual. icon indicates the reference manual.
The contents of the manuals described in this course are those of the following versions.The contents of the manuals described in this course are those of the following versions.
If the versions differ, the location of description and contents may be slightly different.If the versions differ, the location of description and contents may be slightly different.
For the latest version of each manual, refer to the Mitsubishi Electric FA Website.For the latest version of each manual, refer to the Mitsubishi Electric FA Website.

Manual nameManual name Manual No.Manual No. VersionVersion

MELSEC iQ-R Motion Module User's Manual (Startup)MELSEC iQ-R Motion Module User's Manual (Startup) IB-0300406IB-0300406 FF

MELSEC iQ-R Motion Module User's Manual (Network)MELSEC iQ-R Motion Module User's Manual (Network) IB-0300426IB-0300426 FF

MELSEC iQ-R Motion Module User's ManualMELSEC iQ-R Motion Module User's Manual
(Application for Simple Motion Mode)(Application for Simple Motion Mode) IB-0300572IB-0300572 DD

MELSEC iQ-R Motion Module (Simple Motion Mode)MELSEC iQ-R Motion Module (Simple Motion Mode)
Function Block ReferenceFunction Block Reference BCN-B62005-1040BCN-B62005-1040 BB

MELSEC iQ-F FX5 Motion Module/ Simple Motion Module User'sMELSEC iQ-F FX5 Motion Module/ Simple Motion Module User's
Manual (Startup)Manual (Startup)

IB-0300251IB-0300251 HH

MELSEC iQ-F FX5 Motion Module/ Simple Motion Module User'sMELSEC iQ-F FX5 Motion Module/ Simple Motion Module User's
Manual (Application)Manual (Application) IB-0300253IB-0300253 JJ

MELSEC iQ-F FX5 Motion Module User's Manual (CC-Link IE TSN)MELSEC iQ-F FX5 Motion Module User's Manual (CC-Link IE TSN) IB-0300568IB-0300568 CC

MELSEC iQ-F FX5 Motion Module/ Simple Motion Module FunctionMELSEC iQ-F FX5 Motion Module/ Simple Motion Module Function
Block ReferenceBlock Reference

BCN-B62005-719BCN-B62005-719 CC



Chapter 1Chapter 1 Overview of Simple Motion ModeOverview of Simple Motion Mode

The RD78G Motion module has two different modes: "PLCopenThe RD78G Motion module has two different modes: "PLCopen®® motion control FB mode" and "Simple Motion mode". motion control FB mode" and "Simple Motion mode".
This chapter describes the overview of Simple Motion mode and differences from the PLCopenThis chapter describes the overview of Simple Motion mode and differences from the PLCopen®® motion control FB mode. motion control FB mode.

1.11.1 What is Simple Motion mode?What is Simple Motion mode?

Simple Motion mode is an operation mode compatible with RD77MS/GF, QD77MS/GF, and FX5-□SSC-S Simple MotionSimple Motion mode is an operation mode compatible with RD77MS/GF, QD77MS/GF, and FX5-□SSC-S Simple Motion
modules.The programming method and parameter settings are almost the same as the Simple Motion modules.modules.The programming method and parameter settings are almost the same as the Simple Motion modules.
It cannot be used with PLCopenIt cannot be used with PLCopen®® motion control FB mode.Therefore, they cannot be used in the same module. motion control FB mode.Therefore, they cannot be used in the same module.



1.21.2 Modules that can use Simple Motion modeModules that can use Simple Motion mode

The following table lists the modules that can use Simple Motion mode.The following table lists the modules that can use Simple Motion mode.

PLC seriesPLC series
Both Simple Motion mode andBoth Simple Motion mode and

PLCopenPLCopen®® motion control FB mode motion control FB mode
PLCopenPLCopen®® motion control motion control

FB mode onlyFB mode only
Simple Motion mode onlySimple Motion mode only

iQ-R seriesiQ-R series

RD78G4RD78G4
RD78G8RD78G8
RD78G16RD78G16
(Note)(Note)

RD78G32RD78G32
RD78G64RD78G64
RD78GHV, RD78GHWRD78GHV, RD78GHW

--

iQ-F seriesiQ-F series -- --
FX5-40SSC-GFX5-40SSC-G
FX5-80SSC-GFX5-80SSC-G

(Note) For RD78G4, 8, and 16, the firmware version 16 or later supports Simple Motion mode.(Note) For RD78G4, 8, and 16, the firmware version 16 or later supports Simple Motion mode.



1.31.3 Differences from PLCopenDifferences from PLCopen®® motion control FB mode motion control FB mode

The following table lists the differences from PLCopenThe following table lists the differences from PLCopen®® motion control FB mode. motion control FB mode.

ItemItem Simple Motion modeSimple Motion mode PLCopenPLCopen®® motion control FB mode motion control FB mode

Programming methodProgramming method Programming with PLC CPUProgramming with PLC CPU Programming with PLC CPU only orProgramming with PLC CPU only or
distributed programming between PLC CPUdistributed programming between PLC CPU
and Motion moduleand Motion module

PositioningPositioning Point table methodPoint table method Executed by Motion control FBExecuted by Motion control FB

Synchronous controlSynchronous control Configured with the synchronous controlConfigured with the synchronous control
parameter to start synchronous control forparameter to start synchronous control for
each axiseach axis

Executed by Motion control FBExecuted by Motion control FB

Engineering toolEngineering tool GX Works3,GX Works3,
Simple Motion Module Setting FunctionSimple Motion Module Setting Function

GX Works3,GX Works3,
Motion Control Setting FunctionMotion Control Setting Function

LoggingLogging Digital oscilloscopeDigital oscilloscope Logging setting function and GX LogViewerLogging setting function and GX LogViewer



1.41.4 Differences from Simple Motion modulesDifferences from Simple Motion modules

The following table lists differences from iQ-R/iQ-F series Simple Motion modules.The following table lists differences from iQ-R/iQ-F series Simple Motion modules.

ItemItem Simple Motion mode of MotionSimple Motion mode of Motion
modulesmodules Simple Motion moduleSimple Motion module

ModelModel RD78G4/8/16RD78G4/8/16
FX5-□SSC-GFX5-□SSC-G

RD77MS, QD77MS,RD77MS, QD77MS,
LD77MS, FX5-□SSC-SLD77MS, FX5-□SSC-S

RD77GF, QD77GFRD77GF, QD77GF

Supported networkSupported network CC-Link IE TSNCC-Link IE TSN SSCNET III/HSSCNET III/H CC-Link IE FieldCC-Link IE Field

Home position return settingHome position return setting Configured with servo amplifierConfigured with servo amplifier
parameters (Note 1)parameters (Note 1)

Configured with axisConfigured with axis
parametersparameters

Configured with servo amplifierConfigured with servo amplifier
parameters (Note 1)parameters (Note 1)

External signal (manualExternal signal (manual
pulser) inputpulser) input

No (Note 2)No (Note 2) YesYes RD77GF: No (Note 2)RD77GF: No (Note 2)
QD77GF: YesQD77GF: Yes

(Note 1) Only the home position address as well as speed and acceleration/deceleration time for high-speed home position(Note 1) Only the home position address as well as speed and acceleration/deceleration time for high-speed home position
return should be configured with the axis parameters of the Simple Motion module.return should be configured with the axis parameters of the Simple Motion module.

(Note 2) When using a manual pulser with a module that has no external signal input, use the high-speed counter module,(Note 2) When using a manual pulser with a module that has no external signal input, use the high-speed counter module,
built- in counter function in CPU (only for iQ-F series), or the high-speed counter module of the network device (onlybuilt- in counter function in CPU (only for iQ-F series), or the high-speed counter module of the network device (only
for CC-Link IE Field) to connect it.for CC-Link IE Field) to connect it.



1.51.5 Summary of This ChapterSummary of This Chapter

In this chapter, you have learned:In this chapter, you have learned:

What is Simple Motion mode?What is Simple Motion mode?

Modules that can use Simple Motion modeModules that can use Simple Motion mode

Differences from PLCopenDifferences from PLCopen®® motion control FB mode motion control FB mode

Differences from Simple Motion modulesDifferences from Simple Motion modules

PointPoint

What is Simple Motion mode?What is Simple Motion mode? Simple Motion mode of Motion modules is an operation mode compatible with Simple Motion modules.Simple Motion mode of Motion modules is an operation mode compatible with Simple Motion modules.

It cannot be used with PLCopenIt cannot be used with PLCopen®® motion control FB mode. motion control FB mode.

Modules that can use SimpleModules that can use Simple
Motion modeMotion mode

The following modules can use Simple Motion mode.The following modules can use Simple Motion mode.

RD78G4/8/16RD78G4/8/16

FX5-□SSC-GFX5-□SSC-G

Differences from PLCopenDifferences from PLCopen®®

motion control FB modemotion control FB mode
In Simple Motion mode, only the PLC CPU side is programmed.In Simple Motion mode, only the PLC CPU side is programmed.

The point table method is used for positioning.The point table method is used for positioning.

Synchronous control is performed by setting the synchronous control parameter and turning on theSynchronous control is performed by setting the synchronous control parameter and turning on the

synchronous control start for each axis.synchronous control start for each axis.

Differences from Simple MotionDifferences from Simple Motion
modulesmodules

The type of supported network and whether the external input (manual pulser input) is provided differ fromThe type of supported network and whether the external input (manual pulser input) is provided differ from
Simple Motion modules.Simple Motion modules.

Unlike SSCNETIII/H compatible Simple motion modules, parameters related to home position return are set onUnlike SSCNETIII/H compatible Simple motion modules, parameters related to home position return are set on
the servo amplifier side.the servo amplifier side.



Chapter 2Chapter 2 System of Simple Motion ModeSystem of Simple Motion Mode

This chapter describes the hardware configuration of the servo system used in this course. This chapter describes the hardware configuration of the servo system used in this course. 

2.12.1 Machine configurationMachine configuration

In this course, we use the machine configuration of the XY table shown below.In this course, we use the machine configuration of the XY table shown below.
X-axis is represented as axis 1 and Y-axis is represented as axis 2. The location of the limit switch is assumed to be the same forX-axis is represented as axis 1 and Y-axis is represented as axis 2. The location of the limit switch is assumed to be the same for
X-axis and Y-axis.X-axis and Y-axis.



2.22.2 System configurationSystem configuration

In this course, we use the following system configuration.In this course, we use the following system configuration.



2.32.3 WiringWiring

This section describes external wiring such as wiring of the power supply for the programmable controller and servo amplifier,This section describes external wiring such as wiring of the power supply for the programmable controller and servo amplifier,
and the connection method of the servo motor.and the connection method of the servo motor.

2.3.12.3.1 Wiring of servo motorWiring of servo motor

A single cable type option MR-AEP1CBL2M-A2-L is used for the power cable and encoder cable of the servo motor.A single cable type option MR-AEP1CBL2M-A2-L is used for the power cable and encoder cable of the servo motor.



2.3.22.3.2 Wiring of power supply and network cablesWiring of power supply and network cables

Power supply wiring to the programmable controllerPower supply wiring to the programmable controller
Wire the power supply to the programmable controller.Wire the power supply to the programmable controller.
Connect the input AC power supply with the power input signal contacts (L and N).Connect the input AC power supply with the power input signal contacts (L and N).
The FG and LG contacts must be grounded with a ground resistance of 100 Ω or less.The FG and LG contacts must be grounded with a ground resistance of 100 Ω or less.

ItemItem Applicable cable sizeApplicable cable size Tightening torqueTightening torque

Power cablePower cable 18 to 14 AWG18 to 14 AWG 1.02 to 1.38 N·m1.02 to 1.38 N·m

Ground cableGround cable 18 to 14 AWG18 to 14 AWG 1.02 to 1.38 N·m1.02 to 1.38 N·m

ItemItem Terminal block sizeTerminal block size Tightening torqueTightening torque

Power cablePower cable M3M3 0.5 to 0.8N·m0.5 to 0.8N·m

GroundGround
cablecable

M3M3
(Use the cable with thickness of 14 AWG or higher.)(Use the cable with thickness of 14 AWG or higher.)

0.5 to 0.8N·m0.5 to 0.8N·m

(1)(1)



2.3.22.3.2 Wiring of power supply and network cablesWiring of power supply and network cables

Power supply wiring to the servo amplifierPower supply wiring to the servo amplifier
Wire the power supply to the main circuit power supply (L1, L2, L3) and control circuit power supply (L11, L21) of the servoWire the power supply to the main circuit power supply (L1, L2, L3) and control circuit power supply (L11, L21) of the servo
amplifier.amplifier.
The following shows a schematic diagram.The actual wiring and applicable cable size differ depending on the capacity.The following shows a schematic diagram.The actual wiring and applicable cable size differ depending on the capacity.
For details, refer to the user's manual (hardware) of the servo amplifier.For details, refer to the user's manual (hardware) of the servo amplifier.
Use a molded-case circuit breaker (MCCB) with the input cables of the main circuit power supply.Use a molded-case circuit breaker (MCCB) with the input cables of the main circuit power supply.
Always connect a magnetic contactor (MC) between the main circuit power supply and the L1/L2/L3 contacts of the servoAlways connect a magnetic contactor (MC) between the main circuit power supply and the L1/L2/L3 contacts of the servo
amplifier.amplifier.

(2)(2)



2.3.22.3.2 Wiring of power supply and network cablesWiring of power supply and network cables

Wiring of network cablesWiring of network cables
Wire the network cables (Ethernet cables).Wire the network cables (Ethernet cables).
Use the Ethernet cables that meet the following standards.Use the Ethernet cables that meet the following standards.

CommunicationCommunication
speedspeed

Ethernet cableEthernet cable ConnectorConnector StandardStandard

1Gbps1Gbps Category 5e or higher,Category 5e or higher,
(double shielded/STP) straight cable(double shielded/STP) straight cable RJ45 connectorRJ45 connector

Cable that meets the followingCable that meets the following
standards.standards.

IEEE802.3(1000BASE-T)IEEE802.3(1000BASE-T)
ANSI/TIA/EIA-568-BANSI/TIA/EIA-568-B
(Category5e)(Category5e)

(3)(3)



2.3.32.3.3 Wiring of peripheral circuitsWiring of peripheral circuits

(Note) Since the STO function is not used in this course, do not remove the CN8 short-circuit connector attached with the(Note) Since the STO function is not used in this course, do not remove the CN8 short-circuit connector attached with the
servo amplifier.servo amplifier.

I/O circuit of the amplifierI/O circuit of the amplifier
Wire the I/O circuit of the servo amplifier as shown below for both axis 1 and axis 2.Wire the I/O circuit of the servo amplifier as shown below for both axis 1 and axis 2.
Wire the proximity dog, forward/reverse rotation limits, and forced stop.Wire the proximity dog, forward/reverse rotation limits, and forced stop.
In addition, configure the circuit so that the magnetic contactor is turned off by the ALM output.In addition, configure the circuit so that the magnetic contactor is turned off by the ALM output.

(1)(1)



2.3.32.3.3 Wiring of peripheral circuitsWiring of peripheral circuits

External circuit of the input moduleExternal circuit of the input module
The following shows the external circuit wiring of the input module.The following shows the external circuit wiring of the input module.
Use momentary switches for all the switches.Use momentary switches for all the switches.

(Note) Since the I/O No. of RX40C7-TS is 0020H, X20 to X28 and X2F are used in the program.(Note) Since the I/O No. of RX40C7-TS is 0020H, X20 to X28 and X2F are used in the program.

(Note) The service 24 V DC power supply for the programmable controller is used for the external input circuit.(Note) The service 24 V DC power supply for the programmable controller is used for the external input circuit.

(2)(2)



2.42.4 Test operationTest operation

After wiring, perform test operation with the servo amplifier alone to check the motion such as rotation direction.After wiring, perform test operation with the servo amplifier alone to check the motion such as rotation direction.
Follow the steps below to perform test operation.Follow the steps below to perform test operation.

Turn off the power of the servo amplifier and programmable controller.Turn off the power of the servo amplifier and programmable controller.
Turn on (up) the DIP switch (SW3-1) of the servo amplifier.Turn on (up) the DIP switch (SW3-1) of the servo amplifier.

Connect the servo amplifier and personal computer with a USB cable or an Ethernet cable. (Note)Connect the servo amplifier and personal computer with a USB cable or an Ethernet cable. (Note)
Turn on the power supply of the servo amplifier. "TST" is displayed in the monitor.Turn on the power supply of the servo amplifier. "TST" is displayed in the monitor.

Start MR Configurator2 and perform test operation (JOG operation).Start MR Configurator2 and perform test operation (JOG operation).

Check the rotation direction and motion of the machine.Check the rotation direction and motion of the machine.

(1)(1)
(2)(2)

(3)(3)
(4)(4)

(5)(5)

(6)(6)



When test operation is finished, turn off the power of the servo amplifier and turn off the DIP switch (SW3-1).When test operation is finished, turn off the power of the servo amplifier and turn off the DIP switch (SW3-1).

(Note) When using an Ethernet cable, change the MR Configurator2 project to a multi-axis project.(Note) When using an Ethernet cable, change the MR Configurator2 project to a multi-axis project.

TipsTips
When multiple servo amplifiers are used, Ethernet connection is convenient because there is no need to change cables.When multiple servo amplifiers are used, Ethernet connection is convenient because there is no need to change cables.
For details, refer to MR Configurator2 Help.For details, refer to MR Configurator2 Help.

(7)(7)



2.52.5 Summary of This ChapterSummary of This Chapter

In this chapter, you have learned:In this chapter, you have learned:

Machine configurationMachine configuration

System configurationSystem configuration

WiringWiring

Test operationTest operation

PointPoint

Machine configurationMachine configuration The target system uses two ball screws to make an X-Y table.The target system uses two ball screws to make an X-Y table.

System configurationSystem configuration For the iQ-R series, connect two MR-J5-G servo amplifiers to the Motion module RD78G4.For the iQ-R series, connect two MR-J5-G servo amplifiers to the Motion module RD78G4.

For the iQ-F series, connect two MR-J5-G servo amplifiers to the Motion module FX5-40SSC-G.For the iQ-F series, connect two MR-J5-G servo amplifiers to the Motion module FX5-40SSC-G.

WiringWiring A servo motor uses single cable type option cables.A servo motor uses single cable type option cables.

Set the fourth octet of the IP address with the rotary switch on the servo amplifier.Set the fourth octet of the IP address with the rotary switch on the servo amplifier.

Connect the proximity dog signal, limit switch, and forced stop switch to the servo amplifier.Connect the proximity dog signal, limit switch, and forced stop switch to the servo amplifier.

Test operationTest operation Change the DIP switch position on the servo amplifier and connect the personal computer.Change the DIP switch position on the servo amplifier and connect the personal computer.

Check the rotation direction of the servo motor with the test operation function of MR Configurator2.Check the rotation direction of the servo motor with the test operation function of MR Configurator2.



Chapter 3Chapter 3 Creating a ProjectCreating a Project

This chapter describes the procedure that begins with creating a project and extends through the setting of each parameter.This chapter describes the procedure that begins with creating a project and extends through the setting of each parameter.
Note that screenshots of the iQ-R series are shown in the following pages.Note that screenshots of the iQ-R series are shown in the following pages.
When using the iQ-F series, please replace them accordingly.When using the iQ-F series, please replace them accordingly.

The project files to be created in this course can be downloaded from the links below.The project files to be created in this course can be downloaded from the links below.

RD78G_SimpleMode_Basics_Sample.zip (1.90MB)RD78G_SimpleMode_Basics_Sample.zip (1.90MB)
FX5-SSC-G_SimpleMode_Basics_Sample.zip (1.17MB)FX5-SSC-G_SimpleMode_Basics_Sample.zip (1.17MB)



3.13.1 Creating a new projectCreating a new project

Select [Project] → [New] in GX Works3.Select [Project] → [New] in GX Works3.
In the following window, select the model of the PLC CPU to be used and the programming language to be used in the PLCIn the following window, select the model of the PLC CPU to be used and the programming language to be used in the PLC
CPU.CPU.
After selecting them, click the [OK] button.After selecting them, click the [OK] button.

When the following window appears, set whether to use the module label and sample comment.When the following window appears, set whether to use the module label and sample comment.
In this course, set both items to "Use".In this course, set both items to "Use".
If either of them is set to "Not use", click the [Setting Change] button and change the setting.If either of them is set to "Not use", click the [Setting Change] button and change the setting.
Click the [OK] button to open the project.Click the [OK] button to open the project.

(1)(1)

(2)(2)



3.13.1 Creating a new projectCreating a new project

Double-click [Module Configuration] in the project tree.Double-click [Module Configuration] in the project tree.
When the following dialog box appears, click the [OK] button.When the following dialog box appears, click the [OK] button.

When the module configuration diagram opens, drag and drop the module from the Element Selection window on the rightWhen the module configuration diagram opens, drag and drop the module from the Element Selection window on the right
side, and create a module configuration diagram in the same way as that for the system configuration diagram (Section 2.2).side, and create a module configuration diagram in the same way as that for the system configuration diagram (Section 2.2).
For the Motion module, drag and drop a module with (S) at the end of the model.For the Motion module, drag and drop a module with (S) at the end of the model.

When the module configuration diagram is complete, right-click the display and select [Parameter] → [Fix].When the module configuration diagram is complete, right-click the display and select [Parameter] → [Fix].
For the iQ-R series, the following message appears. Click the [Yes] button.For the iQ-R series, the following message appears. Click the [Yes] button.

When the following dialog box appears, check that the sample comment and module label are set to "Use".When the following dialog box appears, check that the sample comment and module label are set to "Use".
If either of them is set to "Not use", click the [Setting Change] button and change the setting.If either of them is set to "Not use", click the [Setting Change] button and change the setting.

(3)(3)



Click the [OK] button to complete the setting.Click the [OK] button to complete the setting.



3.23.2 PLC CPU settingPLC CPU setting

In the case of iQ-R series, select [Parameter] → [R04CPU] in the project tree and double-click [CPU Parameter].In the case of iQ-R series, select [Parameter] → [R04CPU] in the project tree and double-click [CPU Parameter].
Click [Link Direct Device Setting] from the setting item list.Click [Link Direct Device Setting] from the setting item list.
Check that the link direct device setting is set to "Extended Mode (iQ-R Series Mode)".Check that the link direct device setting is set to "Extended Mode (iQ-R Series Mode)".
If it is set to "Q Series Compatible Mode", change it to "Extended Mode (iQ-R Series Mode)".If it is set to "Q Series Compatible Mode", change it to "Extended Mode (iQ-R Series Mode)".
When the setting is complete, click the [Apply] button in the lower right corner.When the setting is complete, click the [Apply] button in the lower right corner.



3.33.3 Motion module settingMotion module setting

3.3.13.3.1 Module parameter (motion)Module parameter (motion)

In the project tree, select [Parameter] → [Module Information] → [0000:RD78G4(S)] and double-click [Module ParameterIn the project tree, select [Parameter] → [Module Information] → [0000:RD78G4(S)] and double-click [Module Parameter
(Motion)].(Motion)].
Configure the refresh setting to transfer the values in the buffer memory of the Motion module to devices or module labels inConfigure the refresh setting to transfer the values in the buffer memory of the Motion module to devices or module labels in
the CPU module.the CPU module.
Use the initial values in this course. (The values in the buffer memory will be transferred to the module labels.)Use the initial values in this course. (The values in the buffer memory will be transferred to the module labels.)



3.3.23.3.2 Module parameter (network)Module parameter (network)

In the project tree, select [Parameter] → [Module Information] → [0000:RD78G4(S)] and double-click [Module ParameterIn the project tree, select [Parameter] → [Module Information] → [0000:RD78G4(S)] and double-click [Module Parameter
(Network)].(Network)].
In this section, set the device to be connected to the network and configure the link refresh.In this section, set the device to be connected to the network and configure the link refresh.

Network configuration settingNetwork configuration setting
Select [Basic Settings] from the setting item list and double-click <Detailed Setting> in the Network Configuration SettingsSelect [Basic Settings] from the setting item list and double-click <Detailed Setting> in the Network Configuration Settings
item.item.

[Point][Point]
In [Required Settings], configure the settings such as the station type, IP address, and network number of the controller.In [Required Settings], configure the settings such as the station type, IP address, and network number of the controller.
Description of the settings is omitted here because the initial values are used in this course.Description of the settings is omitted here because the initial values are used in this course.

(1)(1)



3.3.23.3.2 Module parameter (network)Module parameter (network)

Network configuration setting (continued)Network configuration setting (continued)(1)(1)



3.3.23.3.2 Module parameter (network)Module parameter (network)

Network configuration setting (continued)Network configuration setting (continued)(1)(1)



3.3.23.3.2 Module parameter (network)Module parameter (network)

Network configuration setting (continued)Network configuration setting (continued)(1)(1)



3.3.23.3.2 Module parameter (network)Module parameter (network)

Network configuration setting (continued)Network configuration setting (continued)(1)(1)



3.3.23.3.2 Module parameter (network)Module parameter (network)

Network configuration setting (continued)Network configuration setting (continued)(1)(1)



3.3.23.3.2 Module parameter (network)Module parameter (network)

Network configuration setting (continued)Network configuration setting (continued)(1)(1)



3.3.23.3.2 Module parameter (network)Module parameter (network)

Network configuration setting (continued)Network configuration setting (continued)(1)(1)



3.3.23.3.2 Module parameter (network)Module parameter (network)

Network configuration setting (continued)Network configuration setting (continued)(1)(1)



3.3.23.3.2 Module parameter (network)Module parameter (network)

Network configuration setting (continued)Network configuration setting (continued)(1)(1)



3.3.23.3.2 Module parameter (network)Module parameter (network)

Network configuration setting (continued)Network configuration setting (continued)(1)(1)



3.3.23.3.2 Module parameter (network)Module parameter (network)

Parameter settings of the servo amplifierParameter settings of the servo amplifier
When using Simple Motion mode, always set the parameters of the MR-J5-G servo amplifier as shown in the table below.When using Simple Motion mode, always set the parameters of the MR-J5-G servo amplifier as shown in the table below.
How to set the parameters of the servo amplifier is described on the next page.How to set the parameters of the servo amplifier is described on the next page.
Change the values shown in yellow from the initial values.Change the values shown in yellow from the initial values.
Writing values other than the setting values shown in the table below will cause "Servo parameter invalid".Writing values other than the setting values shown in the table below will cause "Servo parameter invalid".
In such a case, the servo parameters are automatically rewritten from the controller to the values in the table below when theIn such a case, the servo parameters are automatically rewritten from the controller to the values in the table below when the
power is turned on again.power is turned on again.

ParameterParameter InitialInitial
valuevalue Setting valueSetting value

BasicBasic
PA06 (Electronic gear numerator) (Note 1)PA06 (Electronic gear numerator) (Note 1) 11

PA07 (Electronic gear denominator) (Note 1)PA07 (Electronic gear denominator) (Note 1) 11 11

ExtensionExtension PC79.0 (DI status read selection) (Note 1)PC79.0 (DI status read selection) (Note 1) 0h0h

EhEh
bit1: Returns the on/off state of DI1 pin.bit1: Returns the on/off state of DI1 pin.
bit2: Returns the on/off state of DI2 pin.bit2: Returns the on/off state of DI2 pin.
bit3: Returns the on/off state of DI3 pin.bit3: Returns the on/off state of DI3 pin.

I/OI/O

PD41.2 (Limit switch enabled statusPD41.2 (Limit switch enabled status
selection)selection)
(Note 1)(Note 1)

0h0h 1h : Enabled only for homing mode1h : Enabled only for homing mode

PD41.3 (Sensor input method selection)PD41.3 (Sensor input method selection)
(Note 1)(Note 1) 0h0h 1h: Input from controller (FLS/RLS/DOG) (Note 3)1h: Input from controller (FLS/RLS/DOG) (Note 3)

PD60.0 (DI pin polarity selection) (Note 1)PD60.0 (DI pin polarity selection) (Note 1) 0h0h

0h0h
bit0: DI pin polarity selection 1 (turned on at 24 Vbit0: DI pin polarity selection 1 (turned on at 24 V
input)input)
bit1: DI pin polarity selection 2 (turned on at 24 Vbit1: DI pin polarity selection 2 (turned on at 24 V
input)input)
bit2: DI pin polarity selection 3 (turned on at 24 Vbit2: DI pin polarity selection 3 (turned on at 24 V
input)input)

PositioningPositioning
controlcontrol

PT01.1 (Speed/acceleration/deceleration unitPT01.1 (Speed/acceleration/deceleration unit
selection) (Note 2)selection) (Note 2) 0h0h 0h0h

PT08 (Homing position data) (Note 1)PT08 (Homing position data) (Note 1) 00 00

PT15 (Software position limit +)PT15 (Software position limit +) 00 00

PT17 (Software position limit -)PT17 (Software position limit -) 00 00

PT29.0 (Device input polarity 1) (Note 1)PT29.0 (Device input polarity 1) (Note 1) 0h0h 1h: Dog detection with on1h: Dog detection with on

(Note)(Note)
1. The parameter is enabled after the Motion module or MR-J5-G is restarted.1. The parameter is enabled after the Motion module or MR-J5-G is restarted.
2. The parameter is enabled after MR-J5-G is restarted.2. The parameter is enabled after MR-J5-G is restarted.
3. Set "Input from controller" even when connecting the external signal to CN3 of the servo amplifier.3. Set "Input from controller" even when connecting the external signal to CN3 of the servo amplifier.

In addition, change the homing method from the initial value in this course.In addition, change the homing method from the initial value in this course.
Set the value as shown in the table below.Set the value as shown in the table below.

ParameterParameter Initial valueInitial value Setting valueSetting value

PositioningPositioning PT45 (HomingPT45 (Homing 37 (method 37: Data set37 (method 37: Data set -33 (Dog type rear end detection - CW direction with-33 (Dog type rear end detection - CW direction with

(2)(2)

When the servo motor resolution is 26 bits: 16When the servo motor resolution is 26 bits: 16
(Rotary servo motor HK series, etc.)(Rotary servo motor HK series, etc.)
When the servo motor resolution is not 26 bits: 1When the servo motor resolution is not 26 bits: 1

controlcontrol method)method) type)type) reference to Z-phase)reference to Z-phase)



3.3.23.3.2 Module parameter (network)Module parameter (network)

Parameter settings of the servo amplifier (continued)Parameter settings of the servo amplifier (continued)(2)(2)
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Parameter settings of the servo amplifier (continued)Parameter settings of the servo amplifier (continued)(2)(2)
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Parameter settings of the servo amplifier (continued)Parameter settings of the servo amplifier (continued)(2)(2)
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Parameter settings of the servo amplifier (continued)Parameter settings of the servo amplifier (continued)(2)(2)
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Parameter settings of the servo amplifier (continued)Parameter settings of the servo amplifier (continued)(2)(2)
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Parameter settings of the servo amplifier (continued)Parameter settings of the servo amplifier (continued)(2)(2)
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Parameter settings of the servo amplifier (continued)Parameter settings of the servo amplifier (continued)(2)(2)
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Parameter settings of the servo amplifier (continued)Parameter settings of the servo amplifier (continued)(2)(2)
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Parameter settings of the servo amplifier (continued)Parameter settings of the servo amplifier (continued)(2)(2)
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Parameter settings of the servo amplifier (continued)Parameter settings of the servo amplifier (continued)(2)(2)
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Parameter settings of the servo amplifier (continued)Parameter settings of the servo amplifier (continued)(2)(2)
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Parameter settings of the servo amplifier (continued)Parameter settings of the servo amplifier (continued)(2)(2)
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Parameter settings of the servo amplifier (continued)Parameter settings of the servo amplifier (continued)(2)(2)
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Parameter settings of the servo amplifier (continued)Parameter settings of the servo amplifier (continued)(2)(2)
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Parameter settings of the servo amplifier (continued)Parameter settings of the servo amplifier (continued)(2)(2)
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Parameter settings of the servo amplifier (continued)Parameter settings of the servo amplifier (continued)(2)(2)
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Parameter settings of the servo amplifier (continued)Parameter settings of the servo amplifier (continued)(2)(2)



3.3.23.3.2 Module parameter (network)Module parameter (network)

Parameter settings of the servo amplifier (continued)Parameter settings of the servo amplifier (continued)(2)(2)



3.3.23.3.2 Module parameter (network)Module parameter (network)

Parameter settings of the servo amplifier (continued)Parameter settings of the servo amplifier (continued)(2)(2)



3.3.33.3.3 Simple Motion module setting (Module extended parameter)Simple Motion module setting (Module extended parameter)

In the project tree, select [Parameter] → [Module Information] → [0000:RD78G4(S)] and double-click [Simple Motion ModuleIn the project tree, select [Parameter] → [Module Information] → [0000:RD78G4(S)] and double-click [Simple Motion Module
Setting (Module Extended Parameter)].Setting (Module Extended Parameter)].
The Simple Motion Module Setting Function window opens.The Simple Motion Module Setting Function window opens.
Configure the Simple Motion mode settings in this window.Configure the Simple Motion mode settings in this window.



3.43.4 Simple Motion mode settingSimple Motion mode setting

Configure the settings in the order of the project tree in the Simple Motion Module Setting Function window.Configure the settings in the order of the project tree in the Simple Motion Module Setting Function window.
This section describes each setting from System Setting to Positioning Data in order.This section describes each setting from System Setting to Positioning Data in order.



3.43.4 Simple Motion mode settingSimple Motion mode setting

Buffer memory of Simple Motion modeBuffer memory of Simple Motion mode

The following pages contain the description of the buffer memory of Simple Motion mode.The following pages contain the description of the buffer memory of Simple Motion mode.
The following provides the basic information on buffer memory such as symbols and setting methods.The following provides the basic information on buffer memory such as symbols and setting methods.

Type of buffer memoryType of buffer memory
There are four main types of buffer memory in Simple Motion mode.There are four main types of buffer memory in Simple Motion mode.
TypeType SymbolSymbol DetailDetail

ParameterParameter [Pr.XX][Pr.XX]
Network-related parameters, axis-independent parameters related to the entire system, parameters toNetwork-related parameters, axis-independent parameters related to the entire system, parameters to
be set according to the machine, etc.be set according to the machine, etc.
They are mainly set by the Simple Motion Module Setting Function.They are mainly set by the Simple Motion Module Setting Function.

PositioningPositioning
datadata [Da.XX][Da.XX] Data to be used for positioning control, such as the target position and target speed.Data to be used for positioning control, such as the target position and target speed.

They are mainly set by the Simple Motion Module Setting Function.They are mainly set by the Simple Motion Module Setting Function.

Control dataControl data [Cd.XX][Cd.XX] Data to be manipulated when any kind of control is performed.Data to be manipulated when any kind of control is performed.
"System control data" controls the entire system and "Axis control data" controls each axis."System control data" controls the entire system and "Axis control data" controls each axis.

Monitor dataMonitor data [Md.XX][Md.XX]
Memory to be used when the operating status of control is monitored.Memory to be used when the operating status of control is monitored.
"System monitor data" is used for monitoring of the entire system and "Axis monitor data" is used for"System monitor data" is used for monitoring of the entire system and "Axis monitor data" is used for
monitoring of each axis.monitoring of each axis.

How to access buffer memoryHow to access buffer memory
There are two ways to access buffer memory.There are two ways to access buffer memory.
One is to specify the buffer memory address directly in the program (U□\Gxxxxx) and the other is to use module labels.One is to specify the buffer memory address directly in the program (U□\Gxxxxx) and the other is to use module labels.
This course uses module labels. The details are described in Chapter 4.This course uses module labels. The details are described in Chapter 4.

(1)(1)

(2)(2)

The buffer memory address is described in the following manuals.The buffer memory address is described in the following manuals.

MELSEC iQ-R Motion Module User's Manual (Application for Simple Motion Mode)MELSEC iQ-R Motion Module User's Manual (Application for Simple Motion Mode)
12.2 List of Buffer Memory Addresses12.2 List of Buffer Memory Addresses

MELSEC iQ-F FX5 Motion Module/ Simple Motion Module User's Manual (Application)MELSEC iQ-F FX5 Motion Module/ Simple Motion Module User's Manual (Application)
11.2 List of Buffer Memory Addresses11.2 List of Buffer Memory Addresses



3.4.13.4.1 System settingSystem setting

Set [System Setting] in the project tree when using the mark detection function.Set [System Setting] in the project tree when using the mark detection function.
In this course, use the initial values because the mark detection function is not used.In this course, use the initial values because the mark detection function is not used.



3.4.23.4.2 Parameters (Axis parameters)Parameters (Axis parameters)

Common parametersCommon parameters
Set the parameters related to the entire system. The parameters in the red frame are described below.Set the parameters related to the entire system. The parameters in the red frame are described below.

[Pr.82:Forced stop valid/invalid selection][Pr.82:Forced stop valid/invalid selection]
Set this parameter to "2: Valid (Buffer Memory)" to execute an emergency stop of all axes at once in the program.Set this parameter to "2: Valid (Buffer Memory)" to execute an emergency stop of all axes at once in the program.
In this case, an emergency stop is executed when the buffer memory of [Cd.158: Forced stop input] is set to "0".In this case, an emergency stop is executed when the buffer memory of [Cd.158: Forced stop input] is set to "0".
In the sample program, it is set to "1:Invalid" since the emergency stop from the controller is not used.In the sample program, it is set to "1:Invalid" since the emergency stop from the controller is not used.

[Pr.152:Maximum number of control axes][Pr.152:Maximum number of control axes]
This parameter is used to keep the operation cycle small when the number of control axes to be used is less than the maximumThis parameter is used to keep the operation cycle small when the number of control axes to be used is less than the maximum
number of control axes for each model.number of control axes for each model.

Servo network composition parametersServo network composition parameters
Set the parameters related to the network. The parameters in the red frame are described below.Set the parameters related to the network. The parameters in the red frame are described below.

[Pr.141:IP address specification], [Pr.142:Multidrop number][Pr.141:IP address specification], [Pr.142:Multidrop number]
Set the IP address of the servo amplifier.Set the IP address of the servo amplifier.
For the multi-axis servo amplifier, specify the A-/B-/C-axis with the multidrop number.For the multi-axis servo amplifier, specify the A-/B-/C-axis with the multidrop number.

[Point][Point]
Clicking the [...] button in the [Pr.141:IP address specification] or [Pr.142:Multidrop number] field displays the list of servoClicking the [...] button in the [Pr.141:IP address specification] or [Pr.142:Multidrop number] field displays the list of servo
amplifiers registered in the network configuration setting.amplifiers registered in the network configuration setting.
YYou can select the servo amplifier to be assigned to the axis from the displayed list.ou can select the servo amplifier to be assigned to the axis from the displayed list.



[Pr.101:Virtual servo amplifier setting][Pr.101:Virtual servo amplifier setting]
When using the servo amplifier as a virtual servo amplifier, set it to "1:Use as Virtual Servo Amplifier".When using the servo amplifier as a virtual servo amplifier, set it to "1:Use as Virtual Servo Amplifier".
The virtual servo amplifier is a function to allow an axis (virtual servo amplifier axis) to generate only commands virtually withoutThe virtual servo amplifier is a function to allow an axis (virtual servo amplifier axis) to generate only commands virtually without
connecting a servo amplifier.connecting a servo amplifier.
Operation can be performed without amplifiers during debugging.Operation can be performed without amplifiers during debugging.



3.4.23.4.2 Parameters (Axis parameters)Parameters (Axis parameters)

Basic parameters 1Basic parameters 1
Set the machine specifications.Set the machine specifications.
(1) By clicking [Compute Basic parameters 1], the setup assistance window pops up.(1) By clicking [Compute Basic parameters 1], the setup assistance window pops up.
(2) Input the machine specifications.(2) Input the machine specifications.
(3) By clicking the [Compute Basic parameters 1] button, basic parameters 1 are calculated.(3) By clicking the [Compute Basic parameters 1] button, basic parameters 1 are calculated.
(4) By clicking [OK], the window is closed and the settings are applied.(4) By clicking [OK], the window is closed and the settings are applied.



3.4.23.4.2 Parameters (Axis parameters)Parameters (Axis parameters)

Basic parameters 2Basic parameters 2
Set the speed limit value and acceleration/deceleration time.Set the speed limit value and acceleration/deceleration time.

[Pr.8:Speed limit value][Pr.8:Speed limit value]
Set the maximum speed for positioning control, homing control, and speed/torque control.Set the maximum speed for positioning control, homing control, and speed/torque control.

[Pr.9:Acceleration time 0], [Pr.10:Deceleration time 0][Pr.9:Acceleration time 0], [Pr.10:Deceleration time 0]
Acceleration time 0 is used to set the time required to reach [Pr.8:Speed limit value] (or [Pr.31:JOG speed limit value] in the caseAcceleration time 0 is used to set the time required to reach [Pr.8:Speed limit value] (or [Pr.31:JOG speed limit value] in the case
of JOG operation control) from speed 0.of JOG operation control) from speed 0.
Deceleration time 0 is used to set the time required to reach speed 0 from [Pr.8:Speed limit value] (or [Pr.31:JOG speed limitDeceleration time 0 is used to set the time required to reach speed 0 from [Pr.8:Speed limit value] (or [Pr.31:JOG speed limit
value] in the case of JOG operation control).value] in the case of JOG operation control).
([Pr.31:JOG speed limit value] is set in detailed parameters 2.)([Pr.31:JOG speed limit value] is set in detailed parameters 2.)
In detailed parameters 2, acceleration time 1 to 3 and deceleration time 1 to 3 can be set.In detailed parameters 2, acceleration time 1 to 3 and deceleration time 1 to 3 can be set.
In Positioning Data (point table) setting, select acceleration/deceleration time 0 to 3.In Positioning Data (point table) setting, select acceleration/deceleration time 0 to 3.



3.4.23.4.2 Parameters (Axis parameters)Parameters (Axis parameters)

Detailed parameters 1Detailed parameters 1
These parameters are set for each axis. The parameters in the red frames are described below.These parameters are set for each axis. The parameters in the red frames are described below.

[Pr.12:Software stroke limit upper limit value], [Pr.13:Software stroke limit lower limit value][Pr.12:Software stroke limit upper limit value], [Pr.13:Software stroke limit lower limit value]
Set the upper and lower limits of the machine motion range during positioning control.Set the upper and lower limits of the machine motion range during positioning control.

[Pr.14:Software stroke limit selection][Pr.14:Software stroke limit selection]
Set whether to apply the software stroke limit to "Feed Current Value" or "Machine Feed Value".Set whether to apply the software stroke limit to "Feed Current Value" or "Machine Feed Value".

[Pr.15:Software stroke limit valid/invalid setting][Pr.15:Software stroke limit valid/invalid setting]
Whether to enable or disable the software stroke limit during JOG operation , inching operation, and manual pulser operation.Whether to enable or disable the software stroke limit during JOG operation , inching operation, and manual pulser operation.
To disable the software stroke limit at all times, set the same value for the upper and lower limits.To disable the software stroke limit at all times, set the same value for the upper and lower limits.

[Pr.22:Input signal logic selection] (Lower limit, Upper limit, and Proximity dog signal)[Pr.22:Input signal logic selection] (Lower limit, Upper limit, and Proximity dog signal)
Switch the logic of the external input signals (upper/lower limit signal (FLS/RLS) and Proximity dog signal (DOG)) from the servoSwitch the logic of the external input signals (upper/lower limit signal (FLS/RLS) and Proximity dog signal (DOG)) from the servo
amplifier or buffer memory.amplifier or buffer memory.

[Point][Point]
Positive Logic and Negative Logic are as shown below.Positive Logic and Negative Logic are as shown below.

[Pr.116:FLS signal selection : Input type], [Pr.117:RLS signal selection : Input type], [Pr.118:DOG signal selection : Input type] Select[Pr.116:FLS signal selection : Input type], [Pr.117:RLS signal selection : Input type], [Pr.118:DOG signal selection : Input type] Select
whether to connect each external input signal to the servo amplifier, use the buffer memory of [Cd.44:External input signalwhether to connect each external input signal to the servo amplifier, use the buffer memory of [Cd.44:External input signal
operation device], or disable them.operation device], or disable them.



3.4.23.4.2 Parameters (Axis parameters)Parameters (Axis parameters)

Detailed parameters 2Detailed parameters 2
These parameters are set for each axis. The parameters in the red frame are described below.These parameters are set for each axis. The parameters in the red frame are described below.

[Pr.25 to Pr.27:Acceleration time 1 to 3] and [Pr.28 to Pr.30:Deceleration time 1 to 3][Pr.25 to Pr.27:Acceleration time 1 to 3] and [Pr.28 to Pr.30:Deceleration time 1 to 3]
Set the acceleration time and deceleration time in the same way as [Pr.9:Acceleration time 0] and [Pr.10:Deceleration time 0].Set the acceleration time and deceleration time in the same way as [Pr.9:Acceleration time 0] and [Pr.10:Deceleration time 0].
For details, refer to the items of Basic parameters 2.For details, refer to the items of Basic parameters 2.
In Positioning Data (point table) setting, select acceleration/deceleration time 0 to 3.In Positioning Data (point table) setting, select acceleration/deceleration time 0 to 3.

[Pr.31:JOG speed limit value][Pr.31:JOG speed limit value]
Set the upper speed limit for JOG operation.Set the upper speed limit for JOG operation.

[Pr.32:JOG operation acceleration time selection][Pr.32:JOG operation acceleration time selection]
Select the acceleration time for JOG operation from acceleration time 0 to 3.Select the acceleration time for JOG operation from acceleration time 0 to 3.

[Pr.33:JOG operation deceleration time selection][Pr.33:JOG operation deceleration time selection]
Select the deceleration time for JOG operation from deceleration time 0 to 3.Select the deceleration time for JOG operation from deceleration time 0 to 3.



3.4.23.4.2 Parameters (Axis parameters)Parameters (Axis parameters)

Home position return parametersHome position return parameters
Set the parameters related to home position return. The parameters in the red frame are described below.Set the parameters related to home position return. The parameters in the red frame are described below.

[Pr.45:Home position address][Pr.45:Home position address]
When the machine home position return is finished, the address of the stop position is changed to the address set here.When the machine home position return is finished, the address of the stop position is changed to the address set here.
At the same time, it is stored in [Md.20: Feed current value] and [Md.21: Machine feed value].At the same time, it is stored in [Md.20: Feed current value] and [Md.21: Machine feed value].

[Pr.46:Home position return speed][Pr.46:Home position return speed]
Set the travel speed when high-speed home position return (positioning number 9002) is executed.Set the travel speed when high-speed home position return (positioning number 9002) is executed.

[Pr.51:Home position return acceleration time selection], [Pr.52:Home position return deceleration time selection][Pr.51:Home position return acceleration time selection], [Pr.52:Home position return deceleration time selection]
Select the acceleration/deceleration time when high-speed home position return (positioning number 9002) is executed fromSelect the acceleration/deceleration time when high-speed home position return (positioning number 9002) is executed from
acceleration time 0 to 3 and deceleration time 0 to 3.acceleration time 0 to 3 and deceleration time 0 to 3.

[Point][Point]
Use the parameters of the servo amplifier to set the homing method and direction.Use the parameters of the servo amplifier to set the homing method and direction.
[Pr.46], [Pr.51], and [Pr.52] are valid only for high-speed home position return.[Pr.46], [Pr.51], and [Pr.52] are valid only for high-speed home position return.

Extended parametersExtended parameters
Configure the settings related to the desired data monitor function. Description of the settings is omitted in this course.Configure the settings related to the desired data monitor function. Description of the settings is omitted in this course.



3.4.33.4.3 Positioning Data (Point table)Positioning Data (Point table)

Set the positioning data (point table) of each axis.Set the positioning data (point table) of each axis.



3.4.33.4.3 Positioning Data (Point table)Positioning Data (Point table)

Operation patternOperation pattern
Select the operation pattern from 0: END / 1: CONT / 3: LOCATION.Select the operation pattern from 0: END / 1: CONT / 3: LOCATION.
The following shows the difference of each setting when Positioning Data No. 1 is executed.The following shows the difference of each setting when Positioning Data No. 1 is executed.

0: END0: END
Only Positioning Data No. 1 is executed.Only Positioning Data No. 1 is executed.
Processing stops at the target position.Processing stops at the target position.

No.No. Operation patternOperation pattern Control methodControl method ･･････ Dwell timeDwell time

11 0: END0: END 01: ABS Linear 101: ABS Linear 1 (t1)(t1)

1: CONT1: CONT
Positioning Data No. 1 is executed and when the machinePositioning Data No. 1 is executed and when the machine
stops at the target position, Positioning Data No. 2 isstops at the target position, Positioning Data No. 2 is
immediately executed.immediately executed.
Processing is repeatedly executed until the positioning dataProcessing is repeatedly executed until the positioning data
where the operation pattern is [0: END].where the operation pattern is [0: END].
Processing stops at the target position.Processing stops at the target position.

No.No. Operation patternOperation pattern Control methodControl method ･･････ Dwell timeDwell time

11 1: CONT1: CONT 01: ABS Linear 101: ABS Linear 1 00

22 1: CONT1: CONT 01: ABS Linear 101: ABS Linear 1 (t2)(t2)

33 0: END0: END 01: ABS Linear 101: ABS Linear 1 (t3)(t3)

(1)(1)



3: LOCATION3: LOCATION
Speed is changed between the Positioning Data No. inSpeed is changed between the Positioning Data No. in
operation and the next Positioning Data No. withoutoperation and the next Positioning Data No. without
deceleration stop.deceleration stop.
Speed change is not performed when the speed is the same.Speed change is not performed when the speed is the same.
Dwell time setting in the middle of the processing is ignored.Dwell time setting in the middle of the processing is ignored.
Processing is repeatedly executed until the positioning dataProcessing is repeatedly executed until the positioning data
where the operation pattern is [0: END].where the operation pattern is [0: END].

No.No. Operation patternOperation pattern Control methodControl method ･･････ Dwell timeDwell time

11 3: LOCATION3: LOCATION 01: ABS Linear 101: ABS Linear 1 (t1)(t1)

22 3: LOCATION3: LOCATION 01: ABS Linear 101: ABS Linear 1 (t2)(t2)

33 0: END0: END 01: ABS Linear 101: ABS Linear 1 (t3)(t3)



3.4.33.4.3 Positioning Data (Point table)Positioning Data (Point table)

Control method and axis to be interpolatedControl method and axis to be interpolated
Select the control method from the following items. For the axis to be interpolated, set another axis number to be used forSelect the control method from the following items. For the axis to be interpolated, set another axis number to be used for
interpolation control.interpolation control.

Control methodControl method DescriptionDescription

01h: ABS Linear 101h: ABS Linear 1 1-axis linear control (ABS)1-axis linear control (ABS)

02h: INC Linear 102h: INC Linear 1 1-axis linear control (INC)1-axis linear control (INC)

03h: Feed 103h: Feed 1 1-axis fixed-feed control1-axis fixed-feed control

04h: FWD V104h: FWD V1 1-axis speed control (forward)1-axis speed control (forward)

05h: RVS V105h: RVS V1 1-axis speed control (reverse)1-axis speed control (reverse)

06h: FWD V/P06h: FWD V/P Speed-position switching control (forward)Speed-position switching control (forward)

07h: RVS V/P07h: RVS V/P Speed-position switching control (reverse)Speed-position switching control (reverse)

08h: FWD P/V08h: FWD P/V Position-speed switching control (forward)Position-speed switching control (forward)

09h: RVS P/V09h: RVS P/V Position-speed switching control (reverse)Position-speed switching control (reverse)

0Ah: ABS Linear 20Ah: ABS Linear 2 2-axis linear interpolation control (ABS)2-axis linear interpolation control (ABS)

0Bh: INC Linear 20Bh: INC Linear 2 2-axis linear interpolation control (INC)2-axis linear interpolation control (INC)

0Ch: Feed 20Ch: Feed 2 2-axis fixed-feed control2-axis fixed-feed control

0Dh: ABS ArcMP0Dh: ABS ArcMP Circular interpolation control with sub pointCircular interpolation control with sub point
designation (ABS)designation (ABS)

0Eh: INC ArcMP0Eh: INC ArcMP Circular interpolation control with sub pointCircular interpolation control with sub point
designation (INC)designation (INC)

0Fh: ABS ArcRGT0Fh: ABS ArcRGT Circular interpolation control with center pointCircular interpolation control with center point
designation (ABS, CW)designation (ABS, CW)

10h: ABS ArcLFT10h: ABS ArcLFT
Circular interpolation control with center pointCircular interpolation control with center point
designation (ABS, CCW)designation (ABS, CCW)

11h: INC ArcRGT11h: INC ArcRGT Circular interpolation control with center pointCircular interpolation control with center point
designation (INC, CW)designation (INC, CW)

12h: INC ArcLFT12h: INC ArcLFT Circular interpolation control with center pointCircular interpolation control with center point
designation (ABS, CCW)designation (ABS, CCW)

13h: FWD V213h: FWD V2 2-axis speed control (forward)2-axis speed control (forward)

14h: RVS V214h: RVS V2 2-axis speed control (reverse)2-axis speed control (reverse)

15h: ABS Linear 315h: ABS Linear 3 3-axis linear interpolation control (ABS)3-axis linear interpolation control (ABS)

16h: INC Linear 316h: INC Linear 3 3-axis linear interpolation control (INC)3-axis linear interpolation control (INC)

17h: Feed 317h: Feed 3 3-axis fixed-feed control3-axis fixed-feed control

18h: FWD V318h: FWD V3 3-axis speed control (forward)3-axis speed control (forward)

19h: RVS V319h: RVS V3 3-axis speed control (reverse)3-axis speed control (reverse)

(2)(2)



1Ah: ABS Linear 41Ah: ABS Linear 4 4-axis linear interpolation control (ABS)4-axis linear interpolation control (ABS)

1Bh: INC Linear 41Bh: INC Linear 4 4-axis linear interpolation control (INC)4-axis linear interpolation control (INC)

1Ch: Feed 41Ch: Feed 4 4-axis fixed-feed control4-axis fixed-feed control

1Dh: FWD V41Dh: FWD V4 4-axis speed control (forward)4-axis speed control (forward)

1Eh: RVS V41Eh: RVS V4 4-axis speed control (reverse)4-axis speed control (reverse)

20h: ABS HldMP20h: ABS HldMP Helical interpolation control with sub pointHelical interpolation control with sub point
designation (ABS)designation (ABS)

21h: INC HldMP21h: INC HldMP Helical interpolation control with sub pointHelical interpolation control with sub point
designation (INC)designation (INC)

22h: ABS HldRGT22h: ABS HldRGT Helical interpolation control with center pointHelical interpolation control with center point
designation (ABS, CW)designation (ABS, CW)

23h: ABS HldLFT23h: ABS HldLFT Helical interpolation control with center pointHelical interpolation control with center point
designation (ABS, CCW)designation (ABS, CCW)

24h: INC HldRGT24h: INC HldRGT Helical interpolation control with center pointHelical interpolation control with center point
designation (INC, CW)designation (INC, CW)

25h: INC HldRGT25h: INC HldRGT Helical interpolation control with center pointHelical interpolation control with center point
designation (ABS, CCW)designation (ABS, CCW)

80h: NOP80h: NOP NOP instructionNOP instruction

81h: Address CHG81h: Address CHG Current value changeCurrent value change

82h: JUMP82h: JUMP JUMP instructionJUMP instruction

83h: LOOP83h: LOOP Start of LOOP to LENDStart of LOOP to LEND

84h:LEND84h:LEND End of LOOP to LENDEnd of LOOP to LEND

[Point][Point]
The interpolation control uses a set of the same number of positioning data for the reference axisThe interpolation control uses a set of the same number of positioning data for the reference axis
and interpolation axis.and interpolation axis.
Setting examples are shown in 3.4.4.Setting examples are shown in 3.4.4.



3.4.33.4.3 Positioning Data (Point table)Positioning Data (Point table)

Acceleration time No. and deceleration time No.Acceleration time No. and deceleration time No.
Select the acceleration time and deceleration time from Acceleration time No. 0 to 3 and deceleration time No. 0 to 3 set withSelect the acceleration time and deceleration time from Acceleration time No. 0 to 3 and deceleration time No. 0 to 3 set with
the axis parameters (refer to 3.4.2).the axis parameters (refer to 3.4.2).

(3)(3)

Positioning addressPositioning address
Set the coordinates of the target position.Set the coordinates of the target position.
The values change depending on the absolute position specification (ABS, absolute system) and relative position specificationThe values change depending on the absolute position specification (ABS, absolute system) and relative position specification
(INC, incremental system).(INC, incremental system).
Refer to the following figures.Refer to the following figures.

Absolute methodAbsolute method
Positioning is carried out to a designated position (absolute address) with reference to the home position.Positioning is carried out to a designated position (absolute address) with reference to the home position.
This address is regarded as the positioning address. (The start point can be anywhere.)This address is regarded as the positioning address. (The start point can be anywhere.)

Incremental systemIncremental system
The position where the machine is currently stopped is regarded as the start point, and positioning is carried out for aThe position where the machine is currently stopped is regarded as the start point, and positioning is carried out for a
designated movement amount in a designated movement direction.designated movement amount in a designated movement direction.

(4)(4)



3.4.33.4.3 Positioning Data (Point table)Positioning Data (Point table)

Arc addressArc address
The values to be input change depending on the circular interpolation method.The values to be input change depending on the circular interpolation method.
ArcMP ∙∙∙∙∙∙∙∙∙∙ Input the coordinates of the sub point.ArcMP ∙∙∙∙∙∙∙∙∙∙ Input the coordinates of the sub point.
ArcRGT/ArcLFT ∙∙∙ Input the coordinates of the center point.ArcRGT/ArcLFT ∙∙∙ Input the coordinates of the center point.
Setting examples are shown in 3.4.4.Setting examples are shown in 3.4.4.

(5)(5)

Command speedCommand speed
Set the command speed for positioning control. Input a value less than or equal to the speed limit.Set the command speed for positioning control. Input a value less than or equal to the speed limit.

(6)(6)

Dwell timeDwell time
Set the dwell time (time from completion of positioning until the positioning completion signal is turned on) in milliseconds.Set the dwell time (time from completion of positioning until the positioning completion signal is turned on) in milliseconds.

(7)(7)



3.4.33.4.3 Positioning Data (Point table)Positioning Data (Point table)

M codeM code
M code is a code number between 0 to 65535 that can be set for each positioning control.M code is a code number between 0 to 65535 that can be set for each positioning control.
It is used to command auxiliary operation such as clamping, drill rotation, and tool change related to the positioning dataIt is used to command auxiliary operation such as clamping, drill rotation, and tool change related to the positioning data
being executed.being executed.
M codes are read from the CPU module and used to command auxiliary operation.M codes are read from the CPU module and used to command auxiliary operation.

M code ON signal output timing (only for the iQ-R series Motion module)M code ON signal output timing (only for the iQ-R series Motion module)
The output (storage) timing of M codes can be set.The output (storage) timing of M codes can be set.

Setting valueSetting value DescriptionDescription Timing chartTiming chart

0: Uses the setting0: Uses the setting
value of M code ONvalue of M code ON
signal output timingsignal output timing

Follows the setting value of theFollows the setting value of the
axis parameter [Pr.18].axis parameter [Pr.18].

[Pr.18] is 0: WITH Mode (Initial value).[Pr.18] is 0: WITH Mode (Initial value).
[Pr.18] is 1: AFTER Mode.[Pr.18] is 1: AFTER Mode.

1: WITH Mode1: WITH Mode Turns on the M code ON signalTurns on the M code ON signal
at the start of positioning andat the start of positioning and
stores the M code in the bufferstores the M code in the buffer
memory.memory.

2: AFTER Mode2: AFTER Mode Turns on the M code ON signalTurns on the M code ON signal
at the end of positioning andat the end of positioning and
stores the M code in the bufferstores the M code in the buffer
memory.memory.

*1 m1 and m2 are M codes set in the positioning data.*1 m1 and m2 are M codes set in the positioning data.

(8)(8)
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3.4.33.4.3 Positioning Data (Point table)Positioning Data (Point table)

ABS direction in degrees (only for the iQ-R series Motion module)ABS direction in degrees (only for the iQ-R series Motion module)
Set the operation of ABS positioning when the control unit is degree and the software stroke limit is disabled.Set the operation of ABS positioning when the control unit is degree and the software stroke limit is disabled.

Setting valueSetting value DescriptionDescription Operation imageOperation image

0: Uses the setting value of ABS0: Uses the setting value of ABS
direction in degreesdirection in degrees

Uses the setting of [Cd.40].Uses the setting of [Cd.40]. [Cd.40] is 0: Shortcut. (Initial value)[Cd.40] is 0: Shortcut. (Initial value)
[Cd.40] is 1: ABS Clockwise.[Cd.40] is 1: ABS Clockwise.
[Cd.40] is 2: ABS Counterclockwise.[Cd.40] is 2: ABS Counterclockwise.

1: ABS Clockwise1: ABS Clockwise Always travels clockwise.Always travels clockwise.

2: ABS Counterclockwise2: ABS Counterclockwise Always travels counterclockwise.Always travels counterclockwise.

3: Shortcut (Direction setting3: Shortcut (Direction setting
invalid)invalid)

Travels in the closest direction toTravels in the closest direction to
the specified address.the specified address.
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3.4.33.4.3 Positioning Data (Point table)Positioning Data (Point table)

Interpolation speed designation method (only for the iQ-R series Motion module)Interpolation speed designation method (only for the iQ-R series Motion module)
Select whether to set the command speed to vector speed or reference axis (major axis) speed during interpolation control.Select whether to set the command speed to vector speed or reference axis (major axis) speed during interpolation control.

Setting valueSetting value DescriptionDescription Operation imageOperation image

0: Uses the setting value of0: Uses the setting value of
Interpolation speedInterpolation speed
designation methoddesignation method

Follows the setting value of theFollows the setting value of the
axis parameter [Pr.20].axis parameter [Pr.20].

[Pr.20] is 0: Vector speed. (Initial value)[Pr.20] is 0: Vector speed. (Initial value)
[Pr.20] is 1: Reference-axis speed.[Pr.20] is 1: Reference-axis speed.

1: Vector speed1: Vector speed The movement speed for theThe movement speed for the
control target is designated, andcontrol target is designated, and
the speed for each axis isthe speed for each axis is
calculated by the Motioncalculated by the Motion
module.module.

2: Reference-axis speed2: Reference-axis speed The axis speed set for theThe axis speed set for the
reference axis is designated, andreference axis is designated, and
the speed for the other axisthe speed for the other axis
carrying out interpolation iscarrying out interpolation is
calculated by the Motioncalculated by the Motion
module.module.
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3.4.43.4.4 Setting examples of positioning dataSetting examples of positioning data

This section provides setting examples of positioning data.This section provides setting examples of positioning data.

Single axis positioningSingle axis positioning
The following shows the setting examples for the operation pattern shown below.The following shows the setting examples for the operation pattern shown below.

Absolute position specificationAbsolute position specification

For both axis 1 and axis 2, data is registered in positioning data No. 1For both axis 1 and axis 2, data is registered in positioning data No. 1
and 2 of the sample program.and 2 of the sample program.

Relative position specificationRelative position specification

(Note) Acceleration time and deceleration time set here are the time(Note) Acceleration time and deceleration time set here are the time
required to reach the axis parameter [Pr.8:Speed limit value] fromrequired to reach the axis parameter [Pr.8:Speed limit value] from
speed 0.speed 0.
When the command speed is less than the speed limit, the actualWhen the command speed is less than the speed limit, the actual
acceleration time and deceleration time are shorter than the timeacceleration time and deceleration time are shorter than the time
set here. (Refer to 3.4.2 Axis parameters - Basic parameters 2.)set here. (Refer to 3.4.2 Axis parameters - Basic parameters 2.)

(1)(1)



3.4.43.4.4 Setting examples of positioning dataSetting examples of positioning data

Interpolation controlInterpolation control
The following shows the setting examples for the operation pattern shown below.The following shows the setting examples for the operation pattern shown below.
The interpolation control uses a set of the same number of positioning data for the reference axis and interpolation axis.The interpolation control uses a set of the same number of positioning data for the reference axis and interpolation axis.
When the interpolation control command is input to the control method for the point table of the reference axis, some fieldsWhen the interpolation control command is input to the control method for the point table of the reference axis, some fields
of the same number in the point table of the interpolation axis are automatically displayed in yellow and reserved.of the same number in the point table of the interpolation axis are automatically displayed in yellow and reserved.

Absolute position specificationAbsolute position specification
The positioning address (coordinates of the target point) and arc address (coordinates of the center point) of the circularThe positioning address (coordinates of the target point) and arc address (coordinates of the center point) of the circular
interpolation area are as follows.interpolation area are as follows.
Positioning address (14000.0, 0.0), center point address (80000.0, 0.0)Positioning address (14000.0, 0.0), center point address (80000.0, 0.0)

(2)(2)



Relative position specificationRelative position specification

Data is registered in positioning data No. 4 to 7 of the sampleData is registered in positioning data No. 4 to 7 of the sample
program.program.

The positioning address (coordinates of the target point) and arc address (coordinates of the center point) of the circularThe positioning address (coordinates of the target point) and arc address (coordinates of the center point) of the circular
interpolation area are as follows.interpolation area are as follows.
The coordinates of the center point are also set relative to the start point.The coordinates of the center point are also set relative to the start point.
Positioning address (11000.0, -33166.2), arc address (50000.0, -33166.2)Positioning address (11000.0, -33166.2), arc address (50000.0, -33166.2)



3.4.43.4.4 Setting examples of positioning dataSetting examples of positioning data

Notes on interpolation controlNotes on interpolation control
When positioning data for interpolation control is created based on the absolute position specification, the point positioned toWhen positioning data for interpolation control is created based on the absolute position specification, the point positioned to
the specified coordinates regardless of the operation start point.the specified coordinates regardless of the operation start point.
Therefore, for example, when interpolation control based on the absolute position specification set on the previous page isTherefore, for example, when interpolation control based on the absolute position specification set on the previous page is
started from a point other than the home position (0.0, 0.0), the axis is always moved to the point (0.0, 50000.0) by the firststarted from a point other than the home position (0.0, 0.0), the axis is always moved to the point (0.0, 50000.0) by the first
positioning (No. 4).positioning (No. 4).
In this case, the path is as follows.In this case, the path is as follows.

To plot the same path regardless of the coordinates of the start point, create positioning data based on the relative positionTo plot the same path regardless of the coordinates of the start point, create positioning data based on the relative position
specification.specification.
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3.4.53.4.5 Data Setting AssistantData Setting Assistant

Data Setting Assistant allows the user to easily set the positioning data for interpolation control.Data Setting Assistant allows the user to easily set the positioning data for interpolation control.
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3.53.5 Summary of This ChapterSummary of This Chapter

In this chapter, you have learned:In this chapter, you have learned:

Creating a new projectCreating a new project

PLC CPU settingPLC CPU setting

Motion module settingMotion module setting

Simple Motion mode settingSimple Motion mode setting

PointPoint

Creating a new projectCreating a new project Create a new GX Works3 project and module configuration diagram. Simple Motion mode is available by registeringCreate a new GX Works3 project and module configuration diagram. Simple Motion mode is available by registering
the Motion module with (S) in the module configuration diagram.the Motion module with (S) in the module configuration diagram.

PLC CPU settingPLC CPU setting Only for the iQ-R series, change Link Direct Device Setting to Extended Mode (iQ-R Series Mode).Only for the iQ-R series, change Link Direct Device Setting to Extended Mode (iQ-R Series Mode).

Motion module settingMotion module setting Open the network configuration window from the module parameter (network) window.Open the network configuration window from the module parameter (network) window.

In the network configuration window, register the servo amplifier to be connected to the Internet and set the IPIn the network configuration window, register the servo amplifier to be connected to the Internet and set the IP
address. PDO mapping is not performed in Simple Motion mode.address. PDO mapping is not performed in Simple Motion mode.

To write the parameters of the servo amplifier from the controller, select the [Parameter Automatic Setting]To write the parameters of the servo amplifier from the controller, select the [Parameter Automatic Setting]

checkbox of the remote station.checkbox of the remote station.

Some servo parameters must be set in Simple Motion mode. Incorrect setting values will cause "Servo parameterSome servo parameters must be set in Simple Motion mode. Incorrect setting values will cause "Servo parameter

invalid" and write correct parameters automatically when the power is turned on again.invalid" and write correct parameters automatically when the power is turned on again.

Simple Motion mode settingSimple Motion mode setting Set the motion-related parameters in the Simple Motion Module Setting Function window.Set the motion-related parameters in the Simple Motion Module Setting Function window.

Set the operation pattern in the point table. Data Setting Assistant helps you register operation patterns ofSet the operation pattern in the point table. Data Setting Assistant helps you register operation patterns of
interpolation control using multiple axes.interpolation control using multiple axes.



Chapter 4Chapter 4 Positioning Control and Interpolation Control ProgramPositioning Control and Interpolation Control Program

This chapter describes the program for operating the initial setting (all axis servo ON),This chapter describes the program for operating the initial setting (all axis servo ON),
JOG operation, and the positioning data set in the previous chapters.JOG operation, and the positioning data set in the previous chapters.

4.14.1 Module label and module FBModule label and module FB

The sample program in this course uses module labels and module FBs.The sample program in this course uses module labels and module FBs.
From the menu, select [View] → [Docking Window] → [Element Selection] to display the Element Selection window.From the menu, select [View] → [Docking Window] → [Element Selection] to display the Element Selection window.
Select [Module] in the Element Selection window to display the module labels and module FBs.Select [Module] in the Element Selection window to display the module labels and module FBs.

[Point][Point]
Module labels are not displayed if Module Label is set to "Not use" when the project is created (refer to 3.1 (2)) and moduleModule labels are not displayed if Module Label is set to "Not use" when the project is created (refer to 3.1 (2)) and module
configuration diagram is created (refer to 3.1 (3)). (The + mark is not displayed.)configuration diagram is created (refer to 3.1 (3)). (The + mark is not displayed.)
In this case, right-click a module label folder and select [Add Module Label] to add a module label.In this case, right-click a module label folder and select [Add Module Label] to add a module label.



4.24.2 How to add module labels and module FBsHow to add module labels and module FBs

This video explains how to add module labels and module FBs.This video explains how to add module labels and module FBs.

[Point][Point]
To wrap the label name as shown in the video, select [View] → [Change Display Format of Device/Label Name] from the menuTo wrap the label name as shown in the video, select [View] → [Change Display Format of Device/Label Name] from the menu
bar and select [Wrapping Ladder Display].bar and select [Wrapping Ladder Display].

In the program display in this course, Comment Display, Statement Display, Note Display, and Display Device are enabled forIn the program display in this course, Comment Display, Statement Display, Note Display, and Display Device are enabled for
explanatory purposes.explanatory purposes.
Select [View] from the menu bar and select [Comment Display], [Statement Display], [Note Display], and [Display Device]Select [View] from the menu bar and select [Comment Display], [Statement Display], [Note Display], and [Display Device]
checkboxes.checkboxes.
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4.34.3 From the initial setting to all axis servo ONFrom the initial setting to all axis servo ON

To use Simple Motion mode of the Motion module, always create a program as shown below.To use Simple Motion mode of the Motion module, always create a program as shown below.

After the programmable controller enters the RUN state, [Synchronization flag] turns ON when the buffer memory becomesAfter the programmable controller enters the RUN state, [Synchronization flag] turns ON when the buffer memory becomes
accessible.accessible.
↓↓
Turn ON [PLC READY].Turn ON [PLC READY].
↓↓
[READY] turns ON.[READY] turns ON.
↓↓
Turn ON [All axis servo ON].Turn ON [All axis servo ON].

[Program example][Program example]

[Point][Point]
The module label of each signal is located as shown below.The module label of each signal is located as shown below.

(iQ-R)(iQ-R) (iQ-F)(iQ-F)



4.44.4 JOG operationJOG operation

The sample program in this course uses the module FB "(Model)_JOG_(Version)" (hereafter referred to as JOGFB) for JOGThe sample program in this course uses the module FB "(Model)_JOG_(Version)" (hereafter referred to as JOGFB) for JOG
operation.operation.
JOGFB is enabled while the input signal i_bEN is ON.JOGFB is enabled while the input signal i_bEN is ON.
By turning ON the input signal i_bFJog or i_bRJog, commands are output from the Motion module to the servo amplifier andBy turning ON the input signal i_bFJog or i_bRJog, commands are output from the Motion module to the servo amplifier and
the workpiece is moved in the specified direction while the signal is ON.the workpiece is moved in the specified direction while the signal is ON.

Pay attention to the following when using JOGFB.Pay attention to the following when using JOGFB.

Since [Cd.181:Forward run JOG start] and [Cd.182:Reverse run JOG start] are turned ON/OFF by JOGFB, do not turnSince [Cd.181:Forward run JOG start] and [Cd.182:Reverse run JOG start] are turned ON/OFF by JOGFB, do not turn
ON/OFF [Cd.181:Forward run JOG start] or [Cd.182:Reverse run JOG start] outside the FB while the FB is running.ON/OFF [Cd.181:Forward run JOG start] or [Cd.182:Reverse run JOG start] outside the FB while the FB is running.

When using multiple JOGFBs, be careful not to use the same target axis.When using multiple JOGFBs, be careful not to use the same target axis.

[Point][Point]
Inching operation is performed when a value other than "0" is input to the FB input i_uInching.Inching operation is performed when a value other than "0" is input to the FB input i_uInching.

For other precautions, refer to the following manuals.For other precautions, refer to the following manuals.

MELSEC iQ-R Motion Module (Simple Motion Mode) Function Block ReferenceMELSEC iQ-R Motion Module (Simple Motion Mode) Function Block Reference
2 Motion Module FB2 Motion Module FB

2.3 M+RD78GS_JOG2.3 M+RD78GS_JOG

MELSEC iQ-R Simple Motion Module Function Block ReferenceMELSEC iQ-R Simple Motion Module Function Block Reference
2 Simple Motion Module FB/Motion Module FB2 Simple Motion Module FB/Motion Module FB

2.3 M+FX5SSC_JOG2.3 M+FX5SSC_JOG

For inching operation, refer to the following manuals.For inching operation, refer to the following manuals.

MELSEC iQ-R Motion Module User's Manual (Application for Simple Motion Mode)MELSEC iQ-R Motion Module User's Manual (Application for Simple Motion Mode)
5 MANUAL CONTROL5 MANUAL CONTROL

5.3 Inching Operation5.3 Inching Operation

MELSEC iQ-F FX5 Motion Module/ Simple Motion Module User's Manual (Application)MELSEC iQ-F FX5 Motion Module/ Simple Motion Module User's Manual (Application)
5 MANUAL CONTROL5 MANUAL CONTROL

5.3 Inching Operation5.3 Inching Operation



4.44.4 JOG operationJOG operation

[Program example][Program example]



4.54.5 Home position return, single positioning, and interpolation controlHome position return, single positioning, and interpolation control

The sample program in this course uses the module FB "(Model)_StartPositioning_(Version)"The sample program in this course uses the module FB "(Model)_StartPositioning_(Version)"
(hereafter referred to as StartPositioningFB) to execute home position return and positioning start.(hereafter referred to as StartPositioningFB) to execute home position return and positioning start.
To execute home position return, enter "9001" as the positioning number and execute the FB.To execute home position return, enter "9001" as the positioning number and execute the FB.
To start positioning, enter the number of the positioning data (point table) as the positioning number and execute the FB.To start positioning, enter the number of the positioning data (point table) as the positioning number and execute the FB.
In the case of interpolation control, execute positioning of the reference axis.In the case of interpolation control, execute positioning of the reference axis.

Pay attention to the following when using StartPositioningFB.Pay attention to the following when using StartPositioningFB.

Since the positioning start signals (Y10 to Y1F) are turned ON/OFF by StartPositioningFB, do not turn ON/OFF themSince the positioning start signals (Y10 to Y1F) are turned ON/OFF by StartPositioningFB, do not turn ON/OFF them
outside the FB while StartPositioningFB is running.outside the FB while StartPositioningFB is running.

When using multiple StartPositioningFBs or when using an FB that operates the same Y signals as those operated byWhen using multiple StartPositioningFBs or when using an FB that operates the same Y signals as those operated by
StartPositioningFB together, provide an interlock to prevent the FBs from being executed at the same time.StartPositioningFB together, provide an interlock to prevent the FBs from being executed at the same time.

When using multiple StartPositioningFBs, be careful not to use the same target axis.When using multiple StartPositioningFBs, be careful not to use the same target axis.

For other precautions, refer to the following manuals.For other precautions, refer to the following manuals.

MELSEC iQ-R Motion Module (Simple Motion Mode) Function Block ReferenceMELSEC iQ-R Motion Module (Simple Motion Mode) Function Block Reference
2 Motion Module FB2 Motion Module FB

2.2 M+RD78GS_StartPositioning2.2 M+RD78GS_StartPositioning

MELSEC iQ-R Simple Motion Module Function Block ReferenceMELSEC iQ-R Simple Motion Module Function Block Reference
2 Simple Motion Module FB/Motion Module FB2 Simple Motion Module FB/Motion Module FB

2.2 M+FX5SSC_StartPositioning2.2 M+FX5SSC_StartPositioning



4.54.5 Home position return, single positioning, and interpolation controlHome position return, single positioning, and interpolation control

[Program example (1/3)][Program example (1/3)]



4.54.5 Home position return, single positioning, and interpolation controlHome position return, single positioning, and interpolation control

[Program example (2/3)][Program example (2/3)]



4.54.5 Home position return, single positioning, and interpolation controlHome position return, single positioning, and interpolation control

[Program example (3/3)][Program example (3/3)]

[Point][Point]
The module label of the BUSY signal (direct input) for each axis is located as shown below.The module label of the BUSY signal (direct input) for each axis is located as shown below.

(iQ-R)(iQ-R) (iQ-F)(iQ-F)



4.54.5 Home position return, single positioning, and interpolation controlHome position return, single positioning, and interpolation control

[Operation patterns in the sample program][Operation patterns in the sample program]

OperationOperation Start signalStart signal Operation patternOperation pattern

Axis 1 singleAxis 1 single
positioningpositioning

For iQ-R: X26For iQ-R: X26
For iQ-F: X6For iQ-F: X6

Axis 2 singleAxis 2 single
positioningpositioning

For iQ-R: X27For iQ-R: X27
For iQ-F: X7For iQ-F: X7

InterpolationInterpolation
controlcontrol

For iQ-R: X28For iQ-R: X28
For iQ-F: X10For iQ-F: X10



4.64.6 Error resetError reset

Errors and warnings can be monitored and errors can be reset by using the module FB "(Model)_OperateError_(Version)"Errors and warnings can be monitored and errors can be reset by using the module FB "(Model)_OperateError_(Version)"
(hereafter referred to as ErrorFB).(hereafter referred to as ErrorFB).
For details of ErrorFB, refer to the following manual.For details of ErrorFB, refer to the following manual.

[Program example][Program example]

MELSEC iQ-R Motion Module (Simple Motion Mode) Function Block ReferenceMELSEC iQ-R Motion Module (Simple Motion Mode) Function Block Reference
2 Motion Module FB2 Motion Module FB

2.9 M+RD78GS_OperateError2.9 M+RD78GS_OperateError

MELSEC iQ-R Simple Motion Module Function Block ReferenceMELSEC iQ-R Simple Motion Module Function Block Reference
2 Simple Motion Module FB/Motion Module FB2 Simple Motion Module FB/Motion Module FB

2.9 M+FX5SSC_OperateError2.9 M+FX5SSC_OperateError



4.74.7 InterlockInterlock

In the sample program, an interlock is provided to ensure the following:In the sample program, an interlock is provided to ensure the following:

JOG operation is not performed during positioning operation.JOG operation is not performed during positioning operation.

A positioning start signal is not turned ON during JOG operation or positioning operation.A positioning start signal is not turned ON during JOG operation or positioning operation.

This interlock condition is an example. Change the condition to suit your system when using the sample program.This interlock condition is an example. Change the condition to suit your system when using the sample program.

[Program example (In the sample program, the program name is Interlock)][Program example (In the sample program, the program name is Interlock)]

[Point][Point]
The module label [Md.26:Axis operation status] of each axis is located as shown below.The module label [Md.26:Axis operation status] of each axis is located as shown below.

(iQ-R)(iQ-R) (iQ-F)(iQ-F)



4.84.8 Operation check of the sample programOperation check of the sample program

Write the sample program to the programmable controller and check the operation.Write the sample program to the programmable controller and check the operation.

4.8.14.8.1 Writing a programWriting a program

For how to connect a personal computer and programmable controller and how to set the connection destination,For how to connect a personal computer and programmable controller and how to set the connection destination,
check the e-learning course for each programmable controller.check the e-learning course for each programmable controller.

After the rebuild all process of the program, follow the steps below to write the program to the programmable controller.After the rebuild all process of the program, follow the steps below to write the program to the programmable controller.

From the GX Works3 menu bar, select [Online] → [Write to PLC] to display the Online Data Operation window.From the GX Works3 menu bar, select [Online] → [Write to PLC] to display the Online Data Operation window.
Click [Select All].Click [Select All].
All checkboxes are selected.All checkboxes are selected.
Click [Execute] to start writing.Click [Execute] to start writing.
As the writing process proceeds, a message appears to confirm flash ROM writing. Click [Yes].As the writing process proceeds, a message appears to confirm flash ROM writing. Click [Yes].
After writing the program, click [OK] to close the window.After writing the program, click [OK] to close the window.
Back to the Online Data Operation window and click [Close] to close the window.Back to the Online Data Operation window and click [Close] to close the window.
This completes writing the program. Cycle the power of the programmable controller.This completes writing the program. Cycle the power of the programmable controller.

(1)(1)
(2)(2)
(3)(3)
(4)(4)
(5)(5)
(6)(6)
(7)(7)





4.8.24.8.2 Operation checkOperation check
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4.8.24.8.2 Operation checkOperation check
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4.8.24.8.2 Operation checkOperation check



4.94.9 Summary of This ChapterSummary of This Chapter

In this chapter, you have learned:In this chapter, you have learned:

Module label and module FBModule label and module FB

How to add module labels and module FBsHow to add module labels and module FBs

From the initial setting to all axis servo ONFrom the initial setting to all axis servo ON

JOG operationJOG operation

Home position return, single positioning, and interpolation controlHome position return, single positioning, and interpolation control

Error resetError reset

InterlockInterlock

Operation checkOperation check

PointPoint

Module label and moduleModule label and module
FBFB The sample program uses module labels and module FBs.The sample program uses module labels and module FBs.

How to add module labelsHow to add module labels
and module FBsand module FBs

Input a module label or module FB by dragging and dropping it from the Element Selection window to the programInput a module label or module FB by dragging and dropping it from the Element Selection window to the program

editor.editor.

From the initial setting toFrom the initial setting to
all axis servo ONall axis servo ON When using Simple Motion mode, always turn ON [PLC READY] and then turn ON [All axis servo ON].When using Simple Motion mode, always turn ON [PLC READY] and then turn ON [All axis servo ON].

JOG operationJOG operation The sample program uses a module FB to execute JOG operation.The sample program uses a module FB to execute JOG operation.

If the EN input of the FB is OFF, JOG operation is not performed even when the forward/reverse run JOG start is turnedIf the EN input of the FB is OFF, JOG operation is not performed even when the forward/reverse run JOG start is turned

ON.ON.

Home position return,Home position return,
single positioning, andsingle positioning, and
interpolation controlinterpolation control

The sample program uses a module FB to execute positioning start and home position return.The sample program uses a module FB to execute positioning start and home position return.

Home position return is executed by entering 9001 as a positioning number.Home position return is executed by entering 9001 as a positioning number.

When a point table number is entered as a positioning number, positioning is performed according to the positioningWhen a point table number is entered as a positioning number, positioning is performed according to the positioning

pattern set in the corresponding point table.pattern set in the corresponding point table.

In the case of interpolation control, positioning is performed only for the reference axis.In the case of interpolation control, positioning is performed only for the reference axis.

Error resetError reset The sample program uses a module FB to monitor alarms and warnings and execute error reset.The sample program uses a module FB to monitor alarms and warnings and execute error reset.

InterlockInterlock The interlock condition of the sample program is an example. Provide an appropriate interlock for your system.The interlock condition of the sample program is an example. Provide an appropriate interlock for your system.

Operation checkOperation check You have checked the operation of the sample program in the video.You have checked the operation of the sample program in the video.



Chapter 5Chapter 5 Digital OscilloscopeDigital Oscilloscope

This chapter describes how to check the operation of the sample program by using a digital oscilloscope.This chapter describes how to check the operation of the sample program by using a digital oscilloscope.

5.15.1 Digital oscilloscopeDigital oscilloscope

A digital oscilloscope has a function to measure and record the I/O signals (X and Y) of the Motion moduleA digital oscilloscope has a function to measure and record the I/O signals (X and Y) of the Motion module
(Simple Motion mode) and buffer memory values.(Simple Motion mode) and buffer memory values.

The following data (number of channels) can be measured at the same time.The following data (number of channels) can be measured at the same time.

Word data: 16 channelsWord data: 16 channels

Bit data: 16 channelsBit data: 16 channels

Note that the maximum number of channels that can be simultaneously displayed as waveform is 8 for both word data and bitNote that the maximum number of channels that can be simultaneously displayed as waveform is 8 for both word data and bit
data.data.



5.25.2 Starting a digital oscilloscopeStarting a digital oscilloscope

[Digital Oscilloscope] is located at the bottom of the project tree in the Simple Motion setup tool.[Digital Oscilloscope] is located at the bottom of the project tree in the Simple Motion setup tool.
Double-click it to open the Digital Oscilloscope window.Double-click it to open the Digital Oscilloscope window.

When "Notice for adding color change function" appears, click [OK] to close the window.When "Notice for adding color change function" appears, click [OK] to close the window.
After that, the Assistant window appears. In this course, we will configure the digital oscilloscope settings in this window.After that, the Assistant window appears. In this course, we will configure the digital oscilloscope settings in this window.
If the Assistant window does not appear, click [Assistant Screen] on the window.If the Assistant window does not appear, click [Assistant Screen] on the window.



5.35.3 Digital oscilloscope settingsDigital oscilloscope settings

Click the Click the  icon on the Assistant window to open the Online Setting window. icon on the Assistant window to open the Online Setting window.
Set as follows in this window.Set as follows in this window.

No.No. DescriptionDescription

(a)(a) To display real-time waveform during measurement, select "DisplayTo display real-time waveform during measurement, select "Display
patterns in real time".patterns in real time".

(b)(b)

Set whether to continue measurement if the personal computer andSet whether to continue measurement if the personal computer and
Motion module is disconnected.Motion module is disconnected.
Select "Valid" to continue measurement even if the connection isSelect "Valid" to continue measurement even if the connection is
interrupted.interrupted.

In this course, select "Display patterns in real time" and set Digital OscilloscopeIn this course, select "Display patterns in real time" and set Digital Oscilloscope
to "Invalid".to "Invalid".

After completing the settings, click [OK] to close the window.After completing the settings, click [OK] to close the window.

When "Display patterns in real time" is selected, precautions are displayed.When "Display patterns in real time" is selected, precautions are displayed.
Check the precautions, and click [OK] to close the window.Check the precautions, and click [OK] to close the window.

* The Online Setting window can also be opened by selecting [Online] → [Online* The Online Setting window can also be opened by selecting [Online] → [Online
Setting] from the tool bar.Setting] from the tool bar.

Online SettingOnline Setting(1)(1)



5.35.3 Digital oscilloscope settingsDigital oscilloscope settings

Click the Click the  icon on the Assistant window to open the Probe icon on the Assistant window to open the Probe
Selection window.Selection window.
Set the data to be measured in this window.Set the data to be measured in this window.

The Probe Selection window can also be opened by selectingThe Probe Selection window can also be opened by selecting
[Edit] → [Probe Selection] from the tool bar or clicking the [Edit] → [Probe Selection] from the tool bar or clicking the  icon icon
on the tool bar.on the tool bar.

Next, select the probe setting method.Next, select the probe setting method.

OptionOption DescriptionDescription

Select from specifiedSelect from specified
purpose probes.purpose probes.

When the measurement purpose isWhen the measurement purpose is
selected from List by specifiedselected from List by specified
purpose at the bottom of thepurpose at the bottom of the
window, the required probes arewindow, the required probes are
automatically set.automatically set.

Select from all probes.Select from all probes. Select this option to manually setSelect this option to manually set
the items to be measured.the items to be measured.

Check or change the setCheck or change the set
probe item.probe item.

Select this option to check orSelect this option to check or
change the probes that havechange the probes that have
already been set.already been set.
It cannot be selected if no probe isIt cannot be selected if no probe is
registered.registered.

This course explains how to manually set probes.This course explains how to manually set probes.
Select "Select from all probes." and click [OK].Select "Select from all probes." and click [OK].

Probe SelectionProbe Selection(2)(2)



5.35.3 Digital oscilloscope settingsDigital oscilloscope settings

No.No. DescriptionDescription

(a)(a)

Select "I/O Signal" or "Buffer memory" from the upperSelect "I/O Signal" or "Buffer memory" from the upper
drop-down box and select the category from the lowerdrop-down box and select the category from the lower
drop-down box.drop-down box.
Then, select the item to be measured from the list underThen, select the item to be measured from the list under
the drop-down box and add the item to the field (d).the drop-down box and add the item to the field (d).
In the case of data for multiple axes (such as Feed currentIn the case of data for multiple axes (such as Feed current
value), select the data of the axis to be measured from thevalue), select the data of the axis to be measured from the
drop-down menu under the list.drop-down menu under the list.

(b)(b) The items selected in the field (a) are added to the probe.The items selected in the field (a) are added to the probe.

(c)(c) The data added to the probe is deleted.The data added to the probe is deleted.

(d)(d) A list of selected probes is displayed.A list of selected probes is displayed.

Register the following items in this course.Register the following items in this course.

BUSY signal of Ax.1BUSY signal of Ax.1

Feed current value of Ax.1Feed current value of Ax.1

Feedrate of Ax.1Feedrate of Ax.1

Feed current value of Ax.2Feed current value of Ax.2

Feedrate of Ax.2Feedrate of Ax.2

After registration, click [OK].After registration, click [OK].
"Registration of probe item is completed." is displayed. Click [OK] to"Registration of probe item is completed." is displayed. Click [OK] to
close the window.close the window.

Probe Selection (continued)Probe Selection (continued)
The Probe Selection window changes. Register the items to be measured in this window.The Probe Selection window changes. Register the items to be measured in this window.

(2)(2)



5.35.3 Digital oscilloscope settingsDigital oscilloscope settings

Click the Click the  icon on the Assistant window to open the Sampling icon on the Assistant window to open the Sampling
Condition window.Condition window.

Set the sampling interval and trigger balance in the "Input" field.Set the sampling interval and trigger balance in the "Input" field.

OptionOption DescriptionDescription

Set from theSet from the
sampling rate.sampling rate.

Set the sampling rate at intervals of N timesSet the sampling rate at intervals of N times
the minimum operation cycle.the minimum operation cycle.
The default number of sampling points isThe default number of sampling points is
16384 for the iQ-R series and 8192 for the iQ-F16384 for the iQ-R series and 8192 for the iQ-F
series. (Note)series. (Note)

Set from the totalSet from the total
sampling time.sampling time.

Set this item to specify the sampling time.Set this item to specify the sampling time.

Trigger BalanceTrigger Balance

Set the measurement rate before and after aSet the measurement rate before and after a
trigger occurs.trigger occurs.
Change the trigger balance mainly dependingChange the trigger balance mainly depending
on whether you want to measure theon whether you want to measure the
waveform before or after a trigger occurs.waveform before or after a trigger occurs.
For example, if a start signal is a trigger,For example, if a start signal is a trigger,
increase the number of points after the triggerincrease the number of points after the trigger
and if an alarm signal is a trigger, increase theand if an alarm signal is a trigger, increase the
number of points before the trigger.number of points before the trigger.

(Note) To change the number of sampling points, use the Initial Setting(Note) To change the number of sampling points, use the Initial Setting
tab in the Sampling Setting window to be opened on the nexttab in the Sampling Setting window to be opened on the next
page.page.

In this course, configure the settings as follows.In this course, configure the settings as follows.

Set from the total sampling time. → 9.0 [s]Set from the total sampling time. → 9.0 [s]

Trigger Balance 99.0%Trigger Balance 99.0%

Click [Calc.>] and confirm the number of sampling points and samplingClick [Calc.>] and confirm the number of sampling points and sampling
time.time.
Click [OK] to close the window.Click [OK] to close the window.

Sampling condition settingSampling condition setting
Set the sampling interval or total sampling time and trigger balance.Set the sampling interval or total sampling time and trigger balance.

(3)(3)



5.35.3 Digital oscilloscope settingsDigital oscilloscope settings

Click the Click the  icon on the tool bar in the Digital Oscilloscope window icon on the tool bar in the Digital Oscilloscope window
or click [Edit] → [Sampling Setting].or click [Edit] → [Sampling Setting].

A different Sampling Setting window from (3) will open.A different Sampling Setting window from (3) will open.
The items set in (3) are displayed in the [Initial Setting] tab.The items set in (3) are displayed in the [Initial Setting] tab.

Select the [Trigger Setting] tab.Select the [Trigger Setting] tab.

In the trigger setting, select the channel to be used as a trigger fromIn the trigger setting, select the channel to be used as a trigger from
the probes that have been set.the probes that have been set.
In this course, set the rising BUSY signal of Ax.1 as a trigger.In this course, set the rising BUSY signal of Ax.1 as a trigger.

For Trigger Mode, select "Bit OR".For Trigger Mode, select "Bit OR".
[BIT] under Trigger Mode turns blue and the BIT probe that has been[BIT] under Trigger Mode turns blue and the BIT probe that has been
set (only the BUSY signal of Ax.1 in this example) is registered in theset (only the BUSY signal of Ax.1 in this example) is registered in the
probe list.probe list.
Click the pattern several times to set Click the pattern several times to set  (rising). (rising).

After completing the settings, click [Complete].After completing the settings, click [Complete].
When "The sampling setting is changed." is displayed, click [OK] toWhen "The sampling setting is changed." is displayed, click [OK] to
close the window.close the window.

Trigger settingTrigger setting
The trigger setting cannot be opened from the Assistant window. Close the Assistant window.The trigger setting cannot be opened from the Assistant window. Close the Assistant window.

(4)(4)



5.45.4 Measurement methodMeasurement method

After the sampling setting, probe selection, and trigger setting, operate the machine to perform measurement.After the sampling setting, probe selection, and trigger setting, operate the machine to perform measurement.

Start sampling by following one of the steps below.Start sampling by following one of the steps below.

Display the Assistant window again and clickDisplay the Assistant window again and click
the the  icon. icon.

Click the Click the  icon on the tool bar in the Digital icon on the tool bar in the Digital
Oscilloscope window.Oscilloscope window.

Click [Action] → [Run].Click [Action] → [Run].

When the measurement starts, the program entersWhen the measurement starts, the program enters
the trigger waiting state.the trigger waiting state.
Status at the left corner of the window changes toStatus at the left corner of the window changes to
[TRIGGER RUN].[TRIGGER RUN].

In this case, execute "Interpolation control" in theIn this case, execute "Interpolation control" in the
sample program.sample program.
When the trigger condition is satisfied, Status at theWhen the trigger condition is satisfied, Status at the
bottom left corner of the window changes tobottom left corner of the window changes to
[TRIGGER ON].[TRIGGER ON].



When the set measurement time (9 [s] before andWhen the set measurement time (9 [s] before and
after the trigger in this example) elapses,after the trigger in this example) elapses,
measurement is finished and sampling data is read.measurement is finished and sampling data is read.
After the data is read, the display becomes as shownAfter the data is read, the display becomes as shown
on the left.on the left.

Status at the bottom left corner of the windowStatus at the bottom left corner of the window
changes to [TRIGGER STOP].changes to [TRIGGER STOP].



5.55.5 Checking the measurement resultChecking the measurement result

No.No. DescriptionDescription

(a-1)(a-1)

The vertical axis of word data.The vertical axis of word data.
Click a colored box on the left to make the lineClick a colored box on the left to make the line
of the measured word data thicker.of the measured word data thicker.
Click [Vertical Optimization] at the bottom toClick [Vertical Optimization] at the bottom to
automatically adjust Division on the vertical axisautomatically adjust Division on the vertical axis
so that the selected word waveform fits withinso that the selected word waveform fits within
the window.the window.

(a-2)(a-2) The name of the selected word data is displayed.The name of the selected word data is displayed.

(b-1)(b-1)
The vertical axis of bit data.The vertical axis of bit data.
Click a number enclosed in a box to make theClick a number enclosed in a box to make the
line of the measured bit data thicker.line of the measured bit data thicker.

(b-2)(b-2) The name of the selected bit data is displayed.The name of the selected bit data is displayed.

(c)(c) Zoom in/out buttons for the vertical axis.Zoom in/out buttons for the vertical axis.

(d)(d) Zoom in/out buttons for the horizontal axis.Zoom in/out buttons for the horizontal axis.

(e)(e)

The position (time) of the horizontal cursors The position (time) of the horizontal cursors 
and and  and a trigger cursor  and a trigger cursor , and the time, and the time
between each cursor are displayed.between each cursor are displayed.
The cursors The cursors  and  and  at the top can be dragged at the top can be dragged
to move their positions.to move their positions.

Clicking Clicking [Vertical Optimization][Vertical Optimization] for the word data (4ch) of the measurement result of "Interpolation control" displays the for the word data (4ch) of the measurement result of "Interpolation control" displays the
following window.following window.

[Point][Point]
Click the Click the  icon on the tool bar or select [View] → [Grid Mode] from the menu bar and select AUTO Grid to automatically icon on the tool bar or select [View] → [Grid Mode] from the menu bar and select AUTO Grid to automatically
adjust the vertical axis and horizontal axis for the measurement data at once.adjust the vertical axis and horizontal axis for the measurement data at once.

Description of the windowDescription of the window
The following describes the function of each part of the measurement result window.The following describes the function of each part of the measurement result window.

(1)(1)



5.55.5 Checking the measurement resultChecking the measurement result

The values on the graph can be checked by displaying the cursor window.The values on the graph can be checked by displaying the cursor window.
Select [View] → [Cursor] from the tool bar to display the cursor window.Select [View] → [Cursor] from the tool bar to display the cursor window.

The values at the point where the graph intersects theThe values at the point where the graph intersects the
vertical axis cursors vertical axis cursors  and  and , the value between A and B,, the value between A and B,
and the value at the point where the graph intersects theand the value at the point where the graph intersects the
horizontal axis cursor horizontal axis cursor  are displayed. are displayed.
The vertical axis cursors The vertical axis cursors    can be dragged to move can be dragged to move
their positions.their positions.

Open the Displaying dump window by following one of theOpen the Displaying dump window by following one of the
steps below.steps below.

Display the Assistant window again and click the Display the Assistant window again and click the 
icon.icon.

Click the Click the  icon on the tool bar in the Digital icon on the tool bar in the Digital
Oscilloscope window.Oscilloscope window.

Click [Edit] → [DUMP].Click [Edit] → [DUMP].

The values of all sampling data are displayed.The values of all sampling data are displayed.

The positions of the horizontal axis cursors The positions of the horizontal axis cursors  and and
trigger cursor trigger cursor  can be displayed as well as the positions can be displayed as well as the positions
of the maximum value and minimum value before/after theof the maximum value and minimum value before/after the
selected point.selected point.

How to check the valuesHow to check the values
1) Checking on the graph1) Checking on the graph

(2)(2)

2) Checking on Displaying dump2) Checking on Displaying dump



5.55.5 Checking the measurement resultChecking the measurement result

Open the Displaying dump window by following one of theOpen the Displaying dump window by following one of the
steps below.steps below.

Display the Assistant window again and click the Display the Assistant window again and click the 
icon.icon.

Click the Click the  icon on the tool bar. icon on the tool bar.

Click [View] → [Two-dimensional Trajectory Display]Click [View] → [Two-dimensional Trajectory Display]
from the menu bar.from the menu bar.

Select the data to be assigned to the X-axis and Y-axis.Select the data to be assigned to the X-axis and Y-axis.
In this example, select Ax.1 Feed current value for the X-axisIn this example, select Ax.1 Feed current value for the X-axis
and Ax.2 Feed current value for the Y-axis.and Ax.2 Feed current value for the Y-axis.

Now you can display the trajectory of the machine movedNow you can display the trajectory of the machine moved
by the interpolation control program.by the interpolation control program.
Click the Click the  icon to replay the changes in the two- icon to replay the changes in the two-
dimensional trajectory over time.dimensional trajectory over time.

Two-dimensional trajectory displayTwo-dimensional trajectory display
Probes can be assigned to the horizontal direction (X direction) and vertical direction (Y direction) of the graph to display aProbes can be assigned to the horizontal direction (X direction) and vertical direction (Y direction) of the graph to display a
two-dimensional graph (trajectory) using the X-/Y-axes.two-dimensional graph (trajectory) using the X-/Y-axes.

(3)(3)



5.65.6 Saving the measurement resultSaving the measurement result

The measurement result can be saved as a file.The measurement result can be saved as a file.

Save a file by following one of the steps below.Save a file by following one of the steps below.

Display the Assistant window again and click the Display the Assistant window again and click the  icon. icon.

Click the Click the  icon on the tool bar in the Digital Oscilloscope icon on the tool bar in the Digital Oscilloscope
window.window.

Click [File] → [Save] from the tool bar.Click [File] → [Save] from the tool bar.

Enter the file name and click [Save].Enter the file name and click [Save].

[Point][Point]
The saved file (.smt) can be converted to the CSV format.The saved file (.smt) can be converted to the CSV format.
Open [File] → [File Option] from the tool bar, select the saved file (.smt),Open [File] → [File Option] from the tool bar, select the saved file (.smt),
and click [Conversion].and click [Conversion].



5.75.7 Summary of This ChapterSummary of This Chapter

In this chapter, you have learned:In this chapter, you have learned:

Digital oscilloscopeDigital oscilloscope

Starting a digital oscilloscopeStarting a digital oscilloscope

Digital oscilloscope settingsDigital oscilloscope settings

Measurement methodMeasurement method

Checking the measurement resultChecking the measurement result

Saving the measurement resultSaving the measurement result

PointPoint

Digital oscilloscopeDigital oscilloscope A digital oscilloscope has a function to measure and record the I/O signals (X and Y) of the Motion module (SimpleA digital oscilloscope has a function to measure and record the I/O signals (X and Y) of the Motion module (Simple
Motion mode) and buffer memory values.Motion mode) and buffer memory values.

For both bit data and word data, 16 channels can be measured at the same time.For both bit data and word data, 16 channels can be measured at the same time.
The maximum number of channels that can be simultaneously displayed as waveform is 8 for both word data and bitThe maximum number of channels that can be simultaneously displayed as waveform is 8 for both word data and bit

data.data.

Starting a digitalStarting a digital
oscilloscopeoscilloscope Double-click "Digital Oscilloscope" in the project tree in the Simple Motion setup tool to start it.Double-click "Digital Oscilloscope" in the project tree in the Simple Motion setup tool to start it.

Digital oscilloscopeDigital oscilloscope
settingssettings

Online Setting: Set whether to display real-time waveform and whether to enable offline data measurement.Online Setting: Set whether to display real-time waveform and whether to enable offline data measurement.

Probe Selection: Set the data to be measured.Probe Selection: Set the data to be measured.

Sampling Condition Setting: Set the sampling interval or total sampling time and trigger balance.Sampling Condition Setting: Set the sampling interval or total sampling time and trigger balance.

Trigger Setting: Set the trigger as the condition for measuring data.Trigger Setting: Set the trigger as the condition for measuring data.

Measurement methodMeasurement method After completing the settings, operate the machine and execute [Run].After completing the settings, operate the machine and execute [Run].

When the trigger condition has been set, data before and after the trigger occurs is measured according to the setWhen the trigger condition has been set, data before and after the trigger occurs is measured according to the set
trigger balance.trigger balance.

Checking the measurementChecking the measurement
resultresult

Waveform of each type of data can be checked by displaying a graph.Waveform of each type of data can be checked by displaying a graph.

The value at a specific time can be checked by operating the cursor on the graph or displaying dump.The value at a specific time can be checked by operating the cursor on the graph or displaying dump.

A two-dimensional trajectory can be displayed to check the X-axis travel amount and Y-axis travel amount.A two-dimensional trajectory can be displayed to check the X-axis travel amount and Y-axis travel amount.

Saving the measurementSaving the measurement
resultresult

The measurement result can be saved as a file (smt).The measurement result can be saved as a file (smt).

The smt file can be converted to the CSV format.The smt file can be converted to the CSV format.



TestTest Final TestFinal Test

Now that you have completed all of the lessons of the Now that you have completed all of the lessons of the MELSEC iQ-R/iQ-F Series Motion Module Basics (Simple MotionMELSEC iQ-R/iQ-F Series Motion Module Basics (Simple Motion
Mode)Mode) Course, you are ready to take the final test. If you are unclear on any of the topics covered, please take this opportunity Course, you are ready to take the final test. If you are unclear on any of the topics covered, please take this opportunity
to review those topics.to review those topics.

There are a total of 5 questions (19 items) in this Final Test.There are a total of 5 questions (19 items) in this Final Test.

You can take the final test as many times as you like.You can take the final test as many times as you like.

Score resultsScore results

The number of correct answers, the number of questions, the percentage of correct answers, and the pass/fail result will appearThe number of correct answers, the number of questions, the percentage of correct answers, and the pass/fail result will appear
on the score page.on the score page.
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Select the correct sentence(s) to describe the specifications of Simple Motion mode of the Motion module.Select the correct sentence(s) to describe the specifications of Simple Motion mode of the Motion module.

Simple Motion mode and PLCopenSimple Motion mode and PLCopen®® motion control FB mode can be used for each axis in a motion control FB mode can be used for each axis in a
single Motion module.single Motion module.

In Simple Motion mode, only the PLC CPU should be programmed.In Simple Motion mode, only the PLC CPU should be programmed.

Simple Motion mode is available in all Motion modules (RD78G(H)□ and FX5-□SSC-G).Simple Motion mode is available in all Motion modules (RD78G(H)□ and FX5-□SSC-G).

For positioning, Simple Motion mode uses the same point table method as the one used by theFor positioning, Simple Motion mode uses the same point table method as the one used by the
Simple Motion module.Simple Motion module.

Since the Motion module has no external input (manual pulser input), prepare a high-speedSince the Motion module has no external input (manual pulser input), prepare a high-speed
counter module separately to use a manual pulser.counter module separately to use a manual pulser.
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Select the correct word to fill in the blank ( ) to complete the sentences below.Select the correct word to fill in the blank ( ) to complete the sentences below.

To execute test operation, change (Q1) of the servo amplifier and turn on the power supply.To execute test operation, change (Q1) of the servo amplifier and turn on the power supply.

Check the rotation direction of the servo motor with the test operation function of (Q2).Check the rotation direction of the servo motor with the test operation function of (Q2).

Set the (Q3) with the rotary switch on the servo amplifier.Set the (Q3) with the rotary switch on the servo amplifier.

Q1Q1

Q2Q2

Q3Q3

Select the appropriate answer.Select the appropriate answer.

Select the appropriate answer.Select the appropriate answer.

Select the appropriate answer.Select the appropriate answer.

Q1:

Q2:

Q3:

1：DIP switch
2：Rotary switch
3：Command switch

1：GX Works3
2：MR Configurator2
3：Motion Control Setting Function

1：IP address
2：Station number
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Select the correct sentence(s) to describe the settings of Simple Motion mode.Select the correct sentence(s) to describe the settings of Simple Motion mode.

Simple Motion mode is available by registering the Motion module with (S) in the moduleSimple Motion mode is available by registering the Motion module with (S) in the module
configuration diagram.configuration diagram.

After registering the servo amplifier in the network configuration window, perform PDOAfter registering the servo amplifier in the network configuration window, perform PDO
mapping.mapping.

To configure Simple Motion mode, use the same window (Motion Control Setting Function) asTo configure Simple Motion mode, use the same window (Motion Control Setting Function) as
the one used for the Motion module.the one used for the Motion module.

Set the acceleration time to the time required to reach the speed limit from speed 0 andSet the acceleration time to the time required to reach the speed limit from speed 0 and
deceleration time to the time required to reach speed 0 from the speed limit.deceleration time to the time required to reach speed 0 from the speed limit.

To plot the same trajectory regardless of the start point of operation during interpolationTo plot the same trajectory regardless of the start point of operation during interpolation
control, create positioning data based on the relative position specification.control, create positioning data based on the relative position specification.
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22 0:10000:1000 3000.00mm/min3000.00mm/min

22 0:10000:1000 3000.00mm/min3000.00mm/min

22 0:10000:1000 3000.00mm/min3000.00mm/min

22 0:10000:1000 3000.00mm/min3000.00mm/min

Q1Q1 Q2 Q2 

Q3Q3 Q4 Q4 

Q5Q5 Q6 Q6 

Q7Q7 Q8 Q8 

Q9Q9 Q10Q10

Complete the following point tables to plot a trajectory as shown onComplete the following point tables to plot a trajectory as shown on
the right figure.the right figure.
Circular interpolation with center point designation is used for arcs.Circular interpolation with center point designation is used for arcs.
The addresses are specified by the absolute position specification.The addresses are specified by the absolute position specification.

[Axis 1][Axis 1]

No.No.
OperationOperation

patternpattern

ControlControl

methodmethod

Axis to beAxis to be

interpolatedinterpolated

AccelerationAcceleration

time No.time No.

DecelerationDeceleration

time No.time No.

PositioningPositioning

addressaddress

ArcArc

addressaddress
Command speedCommand speed

DwellDwell

timetime
M codeM code

11
LOCATIONLOCATION ABSABS

Linear 2Linear 2

0:10000:1000 -51213.2µm-51213.2µm 0 ms0 ms 00

22 CONTCONT (Q1)(Q1) 0:10000:1000 (Q2) µm(Q2) µm (Q3) µm(Q3) µm 100 ms100 ms 00

33 LOCATIONLOCATION (Q4)(Q4) 0:10000:1000 (Q5) µm(Q5) µm (Q6) µm(Q6) µm 0 ms0 ms 00

44
ENDEND ABSABS

Linear 2Linear 2

0:10000:1000 0.0 µm0.0 µm 500 ms500 ms 00

 [Axis 2] [Axis 2]

No.No.
OperationOperation

patternpattern

ControlControl

methodmethod

Axis to beAxis to be

interpolatedinterpolated

AccelerationAcceleration

time No.time No.

DecelerationDeceleration

time No.time No.

PositioningPositioning

addressaddress

ArcArc

addressaddress
Command speedCommand speed

DwellDwell

timetime
M codeM code

11 51213.2µm51213.2µm

22 (Q7) µm(Q7) µm (Q8) µm(Q8) µm

33 (Q9) µm(Q9) µm (Q10) µm(Q10) µm

44 0.0 µm0.0 µm

Select the appropriate answer.Select the appropriate answer. Select the appropriate answer.Select the appropriate answer.

Select the appropriate answer.Select the appropriate answer. Select the appropriate answer.Select the appropriate answer.

Select the appropriate answer.Select the appropriate answer. Select the appropriate answer.Select the appropriate answer.

Select the appropriate answer.Select the appropriate answer. Select the appropriate answer.Select the appropriate answer.

Select the appropriate answer.Select the appropriate answer. Select the appropriate answer.Select the appropriate answer.



Q1:

Q3:

Q5:

• ABS ArcMP
• ABS ArcRGT
• ABS ArcLFT

• -51213.2
• -30000.0
• 30000.0
• 51213.2
• 72426.4

• -51213.2
• 0.0
• 51213.2
• 72426.4

• -51213.2
• 0.0
• 51213.2
• 72426.4

• -51213.2
• 0.0
• 51213.2
• 72426.4

Q7:

Q9:

Q2:

Q4:

Q6:

Q8:

Q10:

• -51213.2
• 0.0
• 51213.2
• 72426.4

• ABS ArcMP
• ABS ArcRGT
• ABS ArcLFT

• -51213.2
• -30000.0
• 30000.0
• 51213.2
• 72426.4

• -51213.2
• -30000.0
• 30000.0
• 51213.2
• 72426.4

• -51213.2
• -30000.0
• 30000.0
• 51213.2
• 72426.4
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Select the correct sentence to describe each setting item for the Digital Oscilloscope function.Select the correct sentence to describe each setting item for the Digital Oscilloscope function.

Q1 Online SettingQ1 Online Setting
Q2 Probe SelectionQ2 Probe Selection
Q3 Sampling SettingQ3 Sampling Setting
Q4 Trigger SettingQ4 Trigger Setting

Q1Q1

Q2Q2

Q3Q3

Q4Q4

Select the appropriate answer.Select the appropriate answer.

Select the appropriate answer.Select the appropriate answer.

Select the appropriate answer.Select the appropriate answer.

Select the appropriate answer.Select the appropriate answer.

Q1:

Q2:

Q3:

1：Set the measurement time and sampling interval.
2：Set the conditions to start and end measurement.
3：Select whether to display waveform in real-time during measurement and whether to
      continue measurement if the connection with the personal computer is interrupted. 
4：Set the I/O signal to be measured and buffer memory.

1：Set the measurement time and sampling interval.
2：Set the conditions to start and end measurement.
3：Select whether to display waveform in real-time during measurement and whether to
      continue measurement if the connection with the personal computer is interrupted. 
4：Set the I/O signal to be measured and buffer memory.

1：Set the measurement time and sampling interval.
2：Set the conditions to start and end measurement.
3：Select whether to display waveform in real-time during measurement and whether to
      continue measurement if the connection with the personal computer is interrupted. 
4：Set the I/O signal to be measured and buffer memory.

1：Set the measurement time and sampling interval.
2：Set the conditions to start and end measurement.
3：Select whether to display waveform in real-time during measurement and whether to
      continue measurement if the connection with the personal computer is interrupted. 
4：Set the I/O signal to be measured and buffer memory.

Q4:
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Select the correct sentence(s) to describe the specifications of Simple Motion mode of the Motion module.Select the correct sentence(s) to describe the specifications of Simple Motion mode of the Motion module.

Simple Motion mode and PLCopenSimple Motion mode and PLCopen®® motion control FB mode can be used for each axis in a motion control FB mode can be used for each axis in a
single Motion module.single Motion module.

In Simple Motion mode, only the PLC CPU should be programmed.In Simple Motion mode, only the PLC CPU should be programmed.

Simple Motion mode is available in all Motion modules (RD78G(H)□ and FX5-□SSC-G).Simple Motion mode is available in all Motion modules (RD78G(H)□ and FX5-□SSC-G).

For positioning, Simple Motion mode uses the same point table method as the one used by theFor positioning, Simple Motion mode uses the same point table method as the one used by the
Simple Motion module.Simple Motion module.

Since the Motion module has no external input (manual pulser input), prepare a high-speedSince the Motion module has no external input (manual pulser input), prepare a high-speed
counter module separately to use a manual pulser.counter module separately to use a manual pulser.



TestTest Final Test 2Final Test 2

Select the correct word to fill in the blank ( ) to complete the sentences below.Select the correct word to fill in the blank ( ) to complete the sentences below.

To execute test operation, change (Q1) of the servo amplifier and turn on the power supply.To execute test operation, change (Q1) of the servo amplifier and turn on the power supply.

Check the rotation direction of the servo motor with the test operation function of (Q2).Check the rotation direction of the servo motor with the test operation function of (Q2).

Set the (Q3) with the rotary switch on the servo amplifier.Set the (Q3) with the rotary switch on the servo amplifier.

Q1Q1

Q2Q2

Q3Q3

1: DIP switch1: DIP switch

2︓MR Configurator22︓MR Configurator2

1: IP address1: IP address

Q1:

Q2:

Q3:

1：DIP switch
2：Rotary switch
3：Command switch

1：GX Works3
2：MR Configurator2
3：Motion Control Setting Function

1：IP address
2：Station number
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Select the correct sentence(s) to describe the settings of Simple Motion mode.Select the correct sentence(s) to describe the settings of Simple Motion mode.

Simple Motion mode is available by registering the Motion module with (S) in the moduleSimple Motion mode is available by registering the Motion module with (S) in the module
configuration diagram.configuration diagram.

After registering the servo amplifier in the network configuration window, perform PDOAfter registering the servo amplifier in the network configuration window, perform PDO
mapping.mapping.

To configure Simple Motion mode, use the same window (Motion Control Setting Function) asTo configure Simple Motion mode, use the same window (Motion Control Setting Function) as
the one used for the Motion module.the one used for the Motion module.

Set the acceleration time to the time required to reach the speed limit from speed 0 andSet the acceleration time to the time required to reach the speed limit from speed 0 and
deceleration time to the time required to reach speed 0 from the speed limit.deceleration time to the time required to reach speed 0 from the speed limit.

To plot the same trajectory regardless of the start point of operation during interpolationTo plot the same trajectory regardless of the start point of operation during interpolation
control, create positioning data based on the relative position specification.control, create positioning data based on the relative position specification.
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22 0:10000:1000 3000.00mm/min3000.00mm/min

22 0:10000:1000 3000.00mm/min3000.00mm/min

22 0:10000:1000 3000.00mm/min3000.00mm/min

22 0:10000:1000 3000.00mm/min3000.00mm/min

Q1Q1 Q2 Q2 

Q3Q3 Q4 Q4 

Q5Q5 Q6 Q6 

Q7Q7 Q8 Q8 

Q9Q9 Q10Q10

Complete the following point tables to plot a trajectory as shown onComplete the following point tables to plot a trajectory as shown on
the right figure.the right figure.
Circular interpolation with center point designation is used for arcs.Circular interpolation with center point designation is used for arcs.
The addresses are specified by the absolute position specification.The addresses are specified by the absolute position specification.

[Axis 1][Axis 1]

No.No.
OperationOperation

patternpattern

ControlControl

methodmethod

Axis to beAxis to be

interpolatedinterpolated

AccelerationAcceleration

time No.time No.

DecelerationDeceleration

time No.time No.

PositioningPositioning

addressaddress

ArcArc

addressaddress
Command speedCommand speed

DwellDwell

timetime
M codeM code

11
LOCATIONLOCATION ABSABS

Linear 2Linear 2

0:10000:1000 -51213.2µm-51213.2µm 0 ms0 ms 00

22 CONTCONT (Q1)(Q1) 0:10000:1000 (Q2) µm(Q2) µm (Q3) µm(Q3) µm 100 ms100 ms 00

33 LOCATIONLOCATION (Q4)(Q4) 0:10000:1000 (Q5) µm(Q5) µm (Q6) µm(Q6) µm 0 ms0 ms 00

44
ENDEND ABSABS

Linear 2Linear 2

0:10000:1000 0.0 µm0.0 µm 500 ms500 ms 00

 [Axis 2] [Axis 2]

No.No.
OperationOperation

patternpattern

ControlControl

methodmethod

Axis to beAxis to be

interpolatedinterpolated

AccelerationAcceleration

time No.time No.

DecelerationDeceleration

time No.time No.

PositioningPositioning

addressaddress

ArcArc

addressaddress
Command speedCommand speed

DwellDwell

timetime
M codeM code

11 51213.2µm51213.2µm

22 (Q7) µm(Q7) µm (Q8) µm(Q8) µm

33 (Q9) µm(Q9) µm (Q10) µm(Q10) µm

44 0.0 µm0.0 µm

ABS ArcRGTABS ArcRGT 0.00.0

ABS ArcRGTABS ArcRGT

30000.030000.0

72426.472426.4

--30000.030000.0 

51213.251213.2 

51213.272426.4 

51213.251213.2 72426.472426.4



Q1:

Q3:

Q5:

• ABS ArcMP
• ABS ArcRGT
• ABS ArcLFT

• -51213.2
• -30000.0
• 30000.0
• 51213.2
• 72426.4

• -51213.2
• 0.0
• 51213.2
• 72426.4

• -51213.2
• 0.0
• 51213.2
• 72426.4

• -51213.2
• 0.0
• 51213.2
• 72426.4

Q7:

Q9:

Q2:

Q4:

Q6:

Q8:

Q10:

• -51213.2
• 0.0
• 51213.2
• 72426.4

• ABS ArcMP
• ABS ArcRGT
• ABS ArcLFT

• -51213.2
• -30000.0
• 30000.0
• 51213.2
• 72426.4

• -51213.2
• -30000.0
• 30000.0
• 51213.2
• 72426.4

• -51213.2
• -30000.0
• 30000.0
• 51213.2
• 72426.4
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Select the correct sentence to describe each setting item for the Digital Oscilloscope function.Select the correct sentence to describe each setting item for the Digital Oscilloscope function.

Q1 Online SettingQ1 Online Setting
Q2 Probe SelectionQ2 Probe Selection
Q3 Sampling SettingQ3 Sampling Setting
Q4 Trigger SettingQ4 Trigger Setting

Q1Q1

Q2Q2

Q3Q3

Q4Q4

Select whether to display waveform in real-time during measurement and whether to continuSelect whether to display waveform in real-time during measurement and whether to continu……

Set the I/O signal to be measured and buffer memory.Set the I/O signal to be measured and buffer memory.

Set the measurement time and sampling interval.Set the measurement time and sampling interval.

Set the conditions to start and end measurement.Set the conditions to start and end measurement.

Q1:

Q2:

Q3:

1：Set the measurement time and sampling interval. 
2：Set the conditions to start and end measurement.
3：Select whether to display waveform in real-time during measurement and whether to       
      continue measurement if the connection with the personal computer is interrupted. 
4：Set the I/O signal to be measured and buffer memory. 

1：Set the measurement time and sampling interval. 
2：Set the conditions to start and end measurement.
3：Select whether to display waveform in real-time during measurement and whether to       
      continue measurement if the connection with the personal computer is interrupted. 
4：Set the I/O signal to be measured and buffer memory. 

1：Set the measurement time and sampling interval. 
2：Set the conditions to start and end measurement.
3：Select whether to display waveform in real-time during measurement and whether to       
      continue measurement if the connection with the personal computer is interrupted. 
4：Set the I/O signal to be measured and buffer memory. 

1：Set the measurement time and sampling interval. 
2：Set the conditions to start and end measurement.
3：Select whether to display waveform in real-time during measurement and whether to       
      continue measurement if the connection with the personal computer is interrupted. 
4：Set the I/O signal to be measured and buffer memory. 

Q4:
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11 22 33 44 55 66 77 88 99 1010
Final Test 1Final Test 1
Final Test 2Final Test 2
Final Test 3Final Test 3
Final Test 4Final Test 4
Final Test 5Final Test 5

Total questions:Total questions: 1919
Correct answers:Correct answers: 1919
Percentage:Percentage: 100100 %%

You have completed the Final Test. You results area as follows.You have completed the Final Test. You results area as follows.
To end the Final Test, proceed to the next page.To end the Final Test, proceed to the next page.

ClearClear



You have completed the You have completed the "MELSEC iQ-R/iQ-F Series Motion Module"MELSEC iQ-R/iQ-F Series Motion Module
Basics (Simple Motion Mode)"Basics (Simple Motion Mode)" Course. Course.

Thank you for taking this course.Thank you for taking this course.

We hope you enjoyed the lessons and the information you acquired in this course is useful for configuringWe hope you enjoyed the lessons and the information you acquired in this course is useful for configuring
systems in the future.systems in the future.

You can review the course as many times as you want.You can review the course as many times as you want.

ReviewReview

CloseClose


	MELSEC iQ-R/iQ-F Series Motion Module Basics (Simple Motion Mode)
	Introduction
	Purpose of the Course
	Course Structure
	How to Use This e-Learning Tool
	Precautions for Use

	Chapter 1 Overview of Simple Motion Mode
	1.1-1 What is Simple Motion mode?
	1.2-1 Modules that can use Simple Motion mode
	1.3-1 Differences from PLCopen® motion control FB mode
	1.4-1 Differences from Simple Motion modules
	1.5-1 Summary of This Chapter

	Chapter 2 System of Simple Motion Mode
	2.1-1 Machine configuration
	2.2-1 System configuration
	2.3.1-1 Wiring of servo motor
	2.3.2-1 Wiring of power supply and network cables
	2.3.2-2 Wiring of power supply and network cables
	2.3.2-3 Wiring of power supply and network cables
	2.3.3-1 Wiring of peripheral circuits
	2.3.3-2 Wiring of peripheral circuits
	2.4-1 Test operation
	2.5-1 Summary of This Chapter

	Chapter 3 Creating a Project
	3-1 Creating a Project
	3.1-1 Creating a new project
	3.1-2 Creating a new project
	3.2-1 PLC CPU setting
	3.3.1-1 Module parameter (motion)
	3.3.2-1 Module parameter (network)
	3.3.2-2 Module parameter (network)
	3.3.2-3 Module parameter (network)
	3.3.2-4 Module parameter (network)
	3.3.3-1 Simple Motion module setting (Module extended parameter)
	3.4-1 Simple Motion mode setting
	3.4-2 Simple Motion mode setting
	3.4.1-1 System setting
	3.4.2-1 Parameters (Axis parameters)
	3.4.2-2 Parameters (Axis parameters)
	3.4.2-3 Parameters (Axis parameters)
	3.4.2-4 Parameters (Axis parameters)
	3.4.2-5 Parameters (Axis parameters)
	3.4.2-6 Parameters (Axis parameters)
	3.4.3-1 Positioning Data (Point table)
	3.4.3-2 Positioning Data (Point table)
	3.4.3-3 Positioning Data (Point table)
	3.4.3-4 Positioning Data (Point table)
	3.4.3-5 Positioning Data (Point table)
	3.4.3-6 Positioning Data (Point table)
	3.4.3-7 Positioning Data (Point table)
	3.4.3-8 Positioning Data (Point table)
	3.4.4-1 Setting examples of positioning data
	3.4.4-2 Setting examples of positioning data
	3.4.4-3 Setting examples of positioning data
	3.4.5-1 Data Setting Assistant
	3.5-1 Summary of This Chapter

	Chapter 4 Positioning Control and Interpolation Control Program
	4.1-1 Module label and module FB
	4.2-1 How to add module labels and module FBsHow FBs
	4.3-1 From the initial setting to all axis servo ONFrom ON
	4.4-1 JOG operation
	4.4-2 JOG operation
	4.5-1 Home position return, single positioning, and interpolation control
	4.5-2 Home position return, single positioning, and interpolation control
	4.5-3 Home position return, single positioning, and interpolation control
	4.5-4 Home position return, single positioning, and interpolation control
	4.5-5 Home position return, single positioning, and interpolation control
	4.6-1 Error reset
	4.7-1 Interlock
	4.8.1-1 Writing a program
	4.8.2 Operation check
	4.9-1 Summary of This Chapter

	Chapter 5 Digital Oscilloscope
	5.1-1 Digital oscilloscope
	5.2-1 Starting a digital oscilloscope
	5.3-1 Digital oscilloscope settings
	5.3-2 Digital oscilloscope settings
	5.3-3 Digital oscilloscope settings
	5.3-4 Digital oscilloscope settings
	5.3-5 Digital oscilloscope settings
	5.4-1 Measurement method
	5.5-1 Checking the measurement result
	5.5-2 Checking the measurement result
	5.5-3 Checking the measurement result
	5.6-1 Saving the measurement result
	5.7-1 Summary of This Chapter

	Final Test
	Final Test 1
	Final Test 2
	Final Test 3
	Final Test 4
	Final Test 5

	You have completed the 
"MELSEC iQ-R/iQ-F Series Motion Module Basics (Simple Motion Mode)" 
Course.



